Bug 1309226 - 'hidden value' flag is not listed in hammer parameter info output
'hidden value' flag is not listed in hammer parameter info output
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: orabin
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1278718
  Show dependency treegraph
 
Reported: 2016-02-17 04:34 EST by Jitendra Yejare
Modified: 2016-07-27 07:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:18:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13750 None None None 2016-04-22 12:10 EDT

  None (edit)
Description Jitendra Yejare 2016-02-17 04:34:45 EST
Description of problem:
hidden value flag is not displayed in the output of hammer sc-param info --id <id>.

Version-Release number of selected component (if applicable):
foreman-1.11.0-0.develop.201601251557git59dc77b.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. From hammer CLI, info some parameter
# hammer sc-param info --id <id>

Actual results:
The 'hidden value' flag for that parameter is not displayed/listed in output.
Output:
#hammer sc-param info --id 319
Ignoring ruby-libvirt-0.5.2 because its extensions are not built.  Try: gem pristine ruby-libvirt --version 0.5.2
Id:              319
Parameter:       admin_password
Default Value:   [123]
Override:        true
Puppet class:    nova::api
Description:     sadsa dsadwq 3r q3rq  f fdfs dfdsf dsd   23e 3rrdsf dsdsfdfdf 323e3                        ewewe#@#@#@#@#@!*()*&(&&$%%#@$#
Type:            array
Required:        false
Validator:       
    Type: 
    Rule: kit,sit
Override values: 
    Merge overrides:     no
    Merge default value: no
    Avoid duplicates:    no
    Order:               hostgroup, organization, fqdn, domain, os
    Values:              
     1) Id:    26
        Match: os=rhel76
        Value: ["sit"]
Environments:    
    KT_Default_Organization_Library_cv_puppet_2
Created at:      2016/01/27 10:18:52
Updated at:      2016/02/17 09:23:59


Expected results:
'hidden value' flag should be added/displayed in info output of sc-param.

Additional info:
Comment 1 Jitendra Yejare 2016-02-17 04:37:50 EST
Created redmine issue http://projects.theforeman.org/issues/13750 from this bug
Comment 3 Bryan Kearney 2016-02-22 06:06:56 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13750 has been closed
-------------
Ori Rabin
Applied in changeset commit:hammer-cli-foreman|b41686566e7c16cb8ad084e7510bd59b32ef21bf.
Comment 5 Jitendra Yejare 2016-03-23 03:25:59 EDT
The issue is still reproducible in Sat 6.2 snap 4.

The hidden value flag is not displayed in the hammer info output of smart class parameter as well as smart variable.


So moving this to Failed QA.
Comment 6 orabin 2016-03-28 03:38:02 EDT
This fix is available in hammer_cli_foreman version 0.6.2.
Snap 4 is using 0.5.1 so this should be tested again when the hammer version is updated or cherry-picked for the next snap.
Comment 8 Kedar Bidarkar 2016-05-24 08:59:53 EDT
 ~]# hammer sc-param info --id 16
[Foreman] Password for admin: 
Id:              16
Parameter:       ca_file
Default Value:   ${$::foreman_scap_client::params::ca_file}
Override:        false
Puppet class:    foreman_scap_client
Description:     
Type:            string
Hidden Value?:   false
Required:        false
Validator:       
    Type: 
    Rule:
Override values: 
    Merge overrides:     no
    Merge default value: no
    Avoid duplicates:    no
    Order:               fqdn, hostgroup, os, domain
    Values:
Environments:    
    production
Created at:      2016/05/19 09:33:41
Updated at:      2016/05/19 09:33:41

We can now see the "hidden value" flag from the hammer cli output.

VERIFIED with sat62-snap12.1
Comment 9 Bryan Kearney 2016-07-27 07:18:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.