Bug 1309258 - With the user token can't login the integrated registry with docker 1.9
With the user token can't login the integrated registry with docker 1.9
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Image Registry (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Michal Minar
Wei Sun
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 05:35 EST by zhou ying
Modified: 2016-02-18 02:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 02:56:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhou ying 2016-02-17 05:35:08 EST
Description of problem:
After login OpenShift, try to login the integrated registry with the user token will meet error.


Version-Release number of selected component (if applicable):
openshift v3.1.1.902
kubernetes v1.2.0-origin
etcd 2.2.2+git
docker 1.9

How reproducible:
always

Steps to Reproduce:
1. Login OpenShift;
2. Get the user token:
  `oc whoami -t`
3. Use the user token to login integrated registry:
 `docker login -u yinzhou -p NlPIqt2SY1B9uIgpfYdCsHQQ-MiCYBItrafunLfVGjo -e yinzhou@redhat.com 172.31.251.67:5000`

Actual results:
Login failed, with error:
Error response from daemon: invalid registry endpoint https://172.31.251.67:5000/v0/: unable to ping registry endpoint https://172.31.251.67:5000/v0/
v2 ping attempt failed with error: Get https://172.31.251.67:5000/v2/: Forbidden
 v1 ping attempt failed with error: Get https://172.31.251.67:5000/v1/_ping: Forbidden. If this private registry supports only HTTP or HTTPS with an unknown CA certificate, please add `--insecure-registry 172.31.251.67:5000` to the daemo
n's arguments. In the case of HTTPS, if you have access to the registry's CA certificate, no need for the flag; simply place the CA certificate at /etc/docker/certs.d/172.31.251.67:5000/ca.crt

Expected results:
Login successfully.

Additional info:
With docker 1.8 will login successfully
Comment 1 zhou ying 2016-02-18 02:56:58 EST
Use the command on wrong host, so not a bug.

Note You need to log in before you can comment on or make changes to this bug.