Bug 1309265 - python-upoints: Provide a Python 3 subpackage
python-upoints: Provide a Python 3 subpackage
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-upoints (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
:
Depends On: 1323365
Blocks: PYTHON3
  Show dependency treegraph
 
Reported: 2016-02-17 05:45 EST by Petr Viktorin
Modified: 2017-06-09 15:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: python-upoints-0.12.2-4.fc26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-09 15:17:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix Python3 patch to use UTF-8 for README (2.04 KB, patch)
2016-08-22 05:36 EDT, Petr Viktorin
no flags Details | Diff
FTBFS fix (2.85 KB, patch)
2017-05-29 14:20 EDT, Charalampos Stratakis
no flags Details | Diff

  None (edit)
Description Petr Viktorin 2016-02-17 05:45:10 EST
Upstream, this software supports Python 3. Please provide a Python 3
package for Fedora.


According to the Python packaging guidelines [0], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [1].

The current best practice is to provide subpackages for the two Python
versions (called "Common SRPM" in the guidelines). Alternatively, if
nothing depends on your Python2 package, you can just switch to Python 3
entirely.

It's fine to do this in Rawhide only.


If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://fedoraproject.org/wiki/Packaging:Python
[1] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
Comment 1 Jan Kurik 2016-02-24 10:23:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Petr Viktorin 2016-08-22 05:36 EDT
Created attachment 1192865 [details]
Fix Python3 patch to use UTF-8 for README

Hi,
This patch should fix the current FTBFS that's due to reading README without a specified encoding (py3 on Koji defaults to ASCII).

The patch is merged upstream [0] but the author doesn't find it important enough for a new release.

[0] https://github.com/JNRowe/upoints/pull/2
Comment 3 Charalampos Stratakis 2017-05-29 14:20 EDT
Created attachment 1283299 [details]
FTBFS fix

Amended the previous patch.

There is an issue with the edist binary when it is invoked under Python 3 which I reported upstream [0].

https://github.com/JNRowe/upoints/issues/3
Comment 4 Fedora Update System 2017-05-31 08:12:57 EDT
python-upoints-0.12.2-4.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8ea5cb9c05
Comment 5 Fedora Update System 2017-05-31 23:22:10 EDT
python-upoints-0.12.2-4.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8ea5cb9c05
Comment 6 Fedora Update System 2017-06-09 15:17:56 EDT
python-upoints-0.12.2-4.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.