This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1309272 - Value of "Used Size" field is always blank
Value of "Used Size" field is always blank
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
x86_64 Linux
medium Severity high
: GA
: 5.6.0
Assigned To: Moti Asayag
Ilanit Stein
rhev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 06:00 EST by Prasad Mukhedkar
Modified: 2017-08-16 10:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:42:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cfme 5.5.0.13 screenshot (93.95 KB, image/png)
2016-05-30 08:56 EDT, Ilanit Stein
no flags Details
cfme 5.6.0.7 screenshot (85.02 KB, image/png)
2016-05-30 08:57 EDT, Ilanit Stein
no flags Details

  None (edit)
Description Prasad Mukhedkar 2016-02-17 06:00:28 EST
Description of problem:

In rhev, "Thin Provisioned" disks consist two sizes actual size and virtual size.  The virtual Machine page in cloudforms dashboard has section named " Datastore Actual Usage Summary " but it doesnt show the correct data. 


Used Size filed is always set blank due to which cloudforms doesnt show 
"Percent Used of Provisioned Size"


Version-Release number of selected component (if applicable):
5.5

How reproducible:
Always 

Steps to Reproduce:
1. Add a rhev provider, Go to virtual machine tab and select a virtual machine to open its property page. 

2. Look for "Datastore Allocation Summary" section, Select the "Number of Disks"
to open disk information tab. 

3. Check "Percent Used of Provisioned Size" and "Used Size" fields. 

Actual results:
"Percent Used of Provisioned Size" and "Used Size" fields are blank

Expected results:

"Used Size" should reflect the actual storage size utilized by disk on the storage. Percent Used of Provisioned Size should show the same value in percentage.

Additional info:


#qemu-img info 5360be1d-4a2c-4623-be3e-3c4e81bf22a3
file format: raw
virtual size: 10G (10737418240 bytes) < Provisioned size 
disk size: 1.8G < Used size


Reproducer system :

https://10.65.200.249/vm_infra/explorer

admin/smartvm
Comment 2 Moti Asayag 2016-05-18 05:13:29 EDT
Fixed as part of fixing bug 1309275
Comment 3 Ilanit Stein 2016-05-30 08:56:04 EDT
Verified on cfme downstream version 5.6.0.7-beta2.6.20160516171555_b1be31f.

Reproduced first on cfme 5.5.0.13.20151201120956_653c0d4,
for a rhel7.2 VM, both thin & thick disks has empty content under "Used size",
and and 0 content under "Percent Used of Provisioned Size".

However, on cfme 5.6.0.7-beta2.6.20160516171555_b1be31f,
these 2 fields seem to have a valid content, for exact same VM disks.
Comment 4 Ilanit Stein 2016-05-30 08:56 EDT
Created attachment 1162796 [details]
cfme 5.5.0.13 screenshot
Comment 5 Ilanit Stein 2016-05-30 08:57 EDT
Created attachment 1162797 [details]
cfme 5.6.0.7 screenshot
Comment 7 errata-xmlrpc 2016-06-29 11:42:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.