This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 13093 - $FORWARD_IPV4 is not analyzed in any initscript
Summary: $FORWARD_IPV4 is not analyzed in any initscript
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-27 06:43 UTC by sergey
Modified: 2014-03-17 02:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-27 06:43:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sergey 2000-06-27 06:43:21 UTC
Variable $FORWARD_IPV4 is not analyzed in any initscript.
Documentation on redhat.com said: It should be analyzed in rc.sysinit, but 
you can check this script - it's not analyzed anywhere.
So you can't to enable IP-routing by Linuxconf, because Linuxconf just 
change this variable.

I know how I can enable routing by "echo 1 > ..../ip_forward", but I'd 
like to get official bugfix from RedHat. (I think RedHat Linux 6.1 has the 
same problem).

Thanks,
Sergey Zhukov

Comment 1 Bill Nottingham 2000-06-27 15:09:42 UTC
linuxconf has been fixed in rawhide; it's an intentional
behavior change.

Comment 2 Joseph Fannin 2000-10-25 16:18:13 UTC
FORWARD_IPV4 is still present in /etc/sysconfig/network in Red Hat 7.  It needs
to be removed at least, since it's misleading.  Better yet, a comment should be
inserted in its place pointing users to sysctl.conf.

Comment 3 Bill Nottingham 2000-10-25 18:38:00 UTC
Nothing should add it; it probably won't get removed on
upgrade (although the settings should be migrated.)


Note You need to log in before you can comment on or make changes to this bug.