Bug 1309314 - Removing abrt removes dracut networkd
Removing abrt removes dracut networkd
Status: CLOSED DUPLICATE of bug 1259865
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 07:52 EST by Jóhann B. Guðmundsson
Modified: 2016-02-22 12:33 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 07:37:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2016-02-17 07:52:01 EST
Description of problem:

When trying to remove abrt from installed system you end up removing dracut-network in the process due to dependency's

# rpm -q --whatrequires dracut-network
kexec-tools-2.0.10-4.fc23.x86_64
# rpm -q --whatrequires kexec-tools
abrt-addon-vmcore-2.7.1-1.fc23.x86_64

Should not the kdump dracut modules that reside in kexec-tools be packed as a separated sub component of dracut?  

Is there any particular reason why dracut is not packaging each of it's modules in a separated sub component of dracut ( dracut-module-$FOO )?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. dnf remove abrt
2. rpm -q --whatrequires dracut-network
3. rpm -q --whatrequires kexec-tools

Actual results:

Removing abrt removes dracut-networkd

Expected results:

removal of uncessary junk like abrt should not result in removal of core component like initrd in the distribution

Additional info:
Comment 1 Harald Hoyer 2016-02-17 09:48:09 EST
kexec-tools needs/wants dracut-network if the kdump target is on network. IMHO, this dependency is bogus anyway.

The real problem here, though, is that dnf removes leaves, which are not needed anymore automatically.

So, abrt-addon-vmcore requires kexec-tools, which requires dracut-network.
Because nothing else requires dracut-network, dnf thinks it can remove dracut-network, too.

Reassigning to dnf.
Comment 2 Honza Silhan 2016-02-22 07:37:01 EST

*** This bug has been marked as a duplicate of bug 1259865 ***
Comment 3 Jóhann B. Guðmundsson 2016-02-22 12:33:32 EST
(In reply to Jan Silhan from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 1259865 ***

Can you explain how this relates to packagekit since I dont use packagekit to install update components, which this the link bug seems to be about?

Note You need to log in before you can comment on or make changes to this bug.