Bug 1309348 - DASD disk is not always brought online by linuxrc
DASD disk is not always brought online by linuxrc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.8
s390x Linux
high Severity high
: rc
: ---
Assigned To: Samantha N. Bueno
Release Test Team
:
Depends On:
Blocks: 1286535
  Show dependency treegraph
 
Reported: 2016-02-17 09:43 EST by Jan Stodola
Modified: 2016-05-10 16:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.21.248-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:47:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2016-02-17 09:43:57 EST
Description of problem:
In some cases, a DASD disk is not brought online by linuxrc. The following conditions help to reproduce this issue:

* 2 CPUs (unable to reproduce with 1 CPU)
* one FBA DASD disk (unable to reproduce with ECKD DASD)
* configuration in CMS config file
* tested in a z/VM guest

Version-Release number of selected component (if applicable):
RHEL-6.7 GA
RHEL-6.8 Alpha (anaconda-13.21.246-1.el6)

How reproducible:
always when the conditions above are met

Steps to Reproduce:
1. see description

Actual results:
DASD is not brought online by linuxrc

Expected results:
DASD is brought online by linuxrc
Comment 1 Jan Stodola 2016-02-17 09:55:11 EST
The following pull request fixes this issue for me:
https://github.com/rhinstaller/anaconda/pull/511
Comment 2 Samantha N. Bueno 2016-02-17 14:44:19 EST
Simple enough to fix and low risk. Thanks for the patch.
Comment 4 Jan Stodola 2016-03-10 09:05:02 EST
No longer reproducible with anaconda-13.21.249-1.el6.
Moving to VERIFIED.
Comment 6 errata-xmlrpc 2016-05-10 16:47:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0798.html

Note You need to log in before you can comment on or make changes to this bug.