Bug 1309350 - Please rebuild the latest check-mk 1.2.6p16 for Nagios 4
Please rebuild the latest check-mk 1.2.6p16 for Nagios 4
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: check-mk (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andrea Veri
Fedora Extras Quality Assurance
:
: 1309757 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 10:10 EST by marcindulak
Modified: 2016-03-06 21:23 EST (History)
3 users (show)

See Also:
Fixed In Version: check-mk-1.2.6p16-2.fc23 check-mk-1.2.6p16-2.fc22 check-mk-1.2.6p16-2.el7 check-mk-1.2.6p16-2.el6 check-mk-1.2.6p16-2.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 20:23:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for building check-mk 1.2.6p16 for Nagios 4 on EPEL7 (2.37 KB, patch)
2016-02-17 10:10 EST, marcindulak
no flags Details | Diff

  None (edit)
Description marcindulak 2016-02-17 10:10:48 EST
Created attachment 1127963 [details]
patch for building check-mk 1.2.6p16 for Nagios 4 on EPEL7

Description of problem:

check-mk must be rebuilt against Nagios 4 due to livestatus dependency on  last_command_check, removed from Nagios 4. See https://tracker.nagios.org/view.php?id=509

attempted check-mk.spec.patch is attached - please verify it is correct.

Another minor issue in the spec file: the defaults and defaults.py files are not used for anything but copied to buildroot. This is confusing. Please either use the defaults file as SETUPCONF=~/.check_mk_setup.conf in setup.sh during the build process or remove the defaults* files from the package.

When submitting to EPEL7 bodhi use Karma stable threshold of 1 - I'll review whether the package works correctly and we won't need to wait 2 weeks for acceptance.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Andrea Veri 2016-02-18 12:44:00 EST
Will provide an updated package soon, ideally tomorrow. I wanted to make a release earlier but got side tracked by gazillion things. 

About the defaults* files I recall upstream referenced paths that weren't correct on RHEL-based systems thus the need to specify these paths manually and update the files every time.

I'll check the resulting defaults* file this time and see if they diverge from the one we ship.
Comment 2 Fedora Update System 2016-02-19 14:52:41 EST
check-mk-1.2.6p16-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5e44413b03
Comment 3 Fedora Update System 2016-02-19 14:52:41 EST
check-mk-1.2.6p16-1.el5 has been submitted as an update to Fedora EPEL 5. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-d46254c783
Comment 4 Fedora Update System 2016-02-19 14:52:42 EST
check-mk-1.2.6p16-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5e44413b03
Comment 5 Fedora Update System 2016-02-19 14:52:57 EST
check-mk-1.2.6p16-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b265e8374d
Comment 6 Fedora Update System 2016-02-19 14:52:58 EST
check-mk-1.2.6p16-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-b86cee6cb6
Comment 7 Fedora Update System 2016-02-20 12:12:12 EST
check-mk-1.2.6p16-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-41fedd9ffa
Comment 8 Fedora Update System 2016-02-20 12:12:14 EST
check-mk-1.2.6p16-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4a7f76bc91
Comment 9 Fedora Update System 2016-02-20 12:12:15 EST
check-mk-1.2.6p16-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-41fedd9ffa
Comment 10 Fedora Update System 2016-02-20 12:12:24 EST
check-mk-1.2.6p16-2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-db20dc38ac
Comment 11 Fedora Update System 2016-02-20 12:12:25 EST
check-mk-1.2.6p16-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6565234a4e
Comment 12 Fedora Update System 2016-02-20 12:12:34 EST
check-mk-1.2.6p16-2.el5 has been submitted as an update to Fedora EPEL 5. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-56173e9c72
Comment 13 Fedora Update System 2016-02-21 01:21:09 EST
check-mk-1.2.6p16-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-41fedd9ffa
Comment 14 Fedora Update System 2016-02-21 01:47:52 EST
check-mk-1.2.6p16-2.el5 has been pushed to the Fedora EPEL 5 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-56173e9c72
Comment 15 Fedora Update System 2016-02-21 01:53:11 EST
check-mk-1.2.6p16-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-db20dc38ac
Comment 16 Fedora Update System 2016-02-21 12:58:13 EST
check-mk-1.2.6p16-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4a7f76bc91
Comment 17 Fedora Update System 2016-02-21 13:27:31 EST
check-mk-1.2.6p16-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6565234a4e
Comment 18 Fedora Update System 2016-02-22 20:22:56 EST
check-mk-1.2.6p16-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2016-03-02 16:51:21 EST
check-mk-1.2.6p16-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 20 marcindulak 2016-03-05 19:04:07 EST
*** Bug 1309757 has been marked as a duplicate of this bug. ***
Comment 21 Fedora Update System 2016-03-05 20:26:22 EST
check-mk-1.2.6p16-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2016-03-06 17:27:46 EST
check-mk-1.2.6p16-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2016-03-06 21:23:45 EST
check-mk-1.2.6p16-2.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.