Bug 1309372 - Remove "Network address" field in fusor-installer
Remove "Network address" field in fusor-installer
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: fusor-installer (Show other bugs)
1.0
All Linux
unspecified Severity medium
: ga
: 1.0
Assigned To: Jason Montleon
Tasos Papaioannou
: Triaged
Depends On:
Blocks: qci-sprint-17
  Show dependency treegraph
 
Reported: 2016-02-17 11:02 EST by Tasos Papaioannou
Modified: 2016-09-13 12:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:26:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tasos Papaioannou 2016-02-17 11:02:08 EST
Description of problem:

fusor-installer requires the user to enter IP address, Network mask, and Network address for the Satellite's provisioning network:

Modify settings as needed, and then proceed with the installation:
1.      Proceed with the values shown
2.           Network interface | eth1
3.                  IP address | 
4.                    Hostname | fusor.example.com
5.                Network mask | 
6.             Network address | 
7.                Host gateway | 10.10.0.254
[...]

Since the network address is the bit-wise and of the IP address and the Network mask, the network address is unnecessary. If the user leaves it blank and attempts to proceed with the installation, an error message appears:

Unable to proceed because of following errors:
  Network address - Invalid IP address


How reproducible:

100%

Steps to Reproduce:
1.) Run fusor-installer.
2.) See fields for IP address, Network mask, and Network address.


Actual results:

User has to enter the network address in addition to the IP address and network mask.

Expected results:

User only has to enter the IP address and network mask.

Additional info:
Comment 1 Jason Montleon 2016-06-17 09:11:50 EDT
Tasos is this still a problem as it works now? Judging by the menu order in the original comment it looks like this was before we started auto-filling values.

If you enter the hostname, IP address, and netmask today all the DHCP info is pre-populated. Even though I don't think it's been tested, it should be possible to use a different network for provisioning (say setting up a dhcp helper/proxy) so I'm not sure completely removing it makes sense. Especially if QE or someone else is able to test such a scenario and it works as expected.
Comment 2 Tasos Papaioannou 2016-06-21 16:28:02 EDT
In the current install, 'DHCP Network address' is automatically populated once the 'IP address' and 'Network mask' fields have been set. I'm find with marking this as verified.

Tested on QCI-1.2-RHEL-7-20160621.t.0.
Comment 8 errata-xmlrpc 2016-09-13 12:26:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.