Bug 1309373 - OSP-D undercloud should be added as an Cloudforms Infra Provider
OSP-D undercloud should be added as an Cloudforms Infra Provider
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - CloudForms (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: Jason Montleon
Thom Carlin
Dan Macpherson
: FutureFeature, Triaged
Depends On: 1351253
Blocks: qci-sprint-17
  Show dependency treegraph
 
Reported: 2016-02-17 11:02 EST by Dave Johnson
Modified: 2016-09-13 12:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:26:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2016-02-17 11:02:34 EST
Description of problem:
=============================
CF supports managing OSP-D but we are not adding it.  It should be added to CF Infra providers as well as linked to the overcloud.
Comment 1 Jason Montleon 2016-07-08 13:51:50 EDT
https://github.com/fusor/fusor/pull/1005 adds OSP-D. There are two caveats to thsi at the moment. We're broken adding OSP providers at the moment because of 

https://bugzilla.redhat.com/show_bug.cgi?id=1351253

I also don't see a way to link the OSP provider to OSP-D via the API, so we're currently not doing this. I have an email out to the CFME team to see if this is currently possible via the API and if not, to get the functionality added.
Comment 2 Jason Montleon 2016-07-13 12:45:18 EDT
https://github.com/fusor/fusor/pull/1023 links osp-d and osp.
Comment 3 John Matthews 2016-07-18 17:17:01 EDT
QCI-1.2-RHEL-7-20160718.t.0
Comment 4 Jason Montleon 2016-07-19 08:53:22 EDT
Note if you see neither OSP or OSP-D registered we're probably still blocked on this by: https://bugzilla.redhat.com/show_bug.cgi?id=1351253

To my knowledge an image with a fix for this hasn't been released so it will probably appear to fail QA.
Comment 9 Thom Carlin 2016-07-26 15:16:25 EDT
During verification using QCI-1.2-RHEL-7-20160723.t.0
QCIOOO-8.0-RHEL-7-20160725.t.0, neither OSP or OSP-D registered. Per comment 4, blocking on 1351253...
Comment 10 Thom Carlin 2016-08-31 16:44:25 EDT
Apparently 1351253 was cloned to https://bugzilla.redhat.com/show_bug.cgi?id=1352011

Checking status
Comment 11 jkim 2016-09-01 15:41:52 EDT
This is ready for QA verification
Comment 12 Landon LaSmith 2016-09-09 11:30:57 EDT
VERIFIED that the OSP-director was added to cloudforms as an infrastructure provider in addition to the overcloud added as a cloud provider.

QCI ISO Version: QCI-1.0-RHEL-7-20160908.1-QCI-x86_64-dvd1.iso
QCIOOO ISO Version: QCIOOO-8.0-RHEL-7-20160907.2-QCIOOO-x86_64-dvd1.iso
Comment 14 errata-xmlrpc 2016-09-13 12:26:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.