Bug 1309384 - enhance post-sync skip detection with simple count check
enhance post-sync skip detection with simple count check
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
6.1.6
Unspecified Unspecified
unspecified Severity high (vote)
: 6.2.5
: --
Assigned To: Martin Bacovsky
jcallaha
: PrioBumpField, Triaged
: 1331378 (view as bug list)
Depends On:
Blocks: 1394359
  Show dependency treegraph
 
Reported: 2016-02-17 11:18 EST by Justin Sherrill
Modified: 2018-02-19 13:59 EST (History)
5 users (show)

See Also:
Fixed In Version: tfm-rubygem-katello-3.0.0.86-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1394359 (view as bug list)
Environment:
Last Closed: 2016-12-12 12:10:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 16827 None None None 2016-10-06 17:58 EDT

  None (edit)
Description Justin Sherrill 2016-02-17 11:18:32 EST
Description of problem:

Currently we rely on pulp to tell us about updated or added units on a sync to determine whether or not to index all the content.  We can probably enhance this a bit by simply checking the counts within the repo to see if it matches what we think should be in the repo.  This check should take less than a second and would catch the case where a sync pulled in packages but was not indexed the first time (such as if the publish errored, or a scheduled sync completion was missed).

This would reduce the number of situations where a user is syncing but not seeing any updated packages.
Comment 2 Bryan Kearney 2016-07-26 11:25:24 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 3 Bryan Kearney 2016-07-26 11:35:56 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 5 Martin Bacovsky 2016-10-06 17:58:27 EDT
Created redmine issue http://projects.theforeman.org/issues/16827 from this bug
Comment 6 Bryan Kearney 2016-10-06 18:15:36 EDT
Upstream bug component is Repositories
Comment 8 Bryan Kearney 2016-10-16 22:15:43 EDT
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/16827 has been resolved.
Comment 9 jcallaha 2016-12-06 14:17:16 EST
Verified in Satellite 6.2.5 Snap 3

1. Created a new repo then sync'd
      step_id: f1cbf9de-5481-4426-a56b-1a93ae55f41d
      num_processed: 1
    - num_success: 303
      description: Publishing RPMs
      step_type: rpms
      items_total: 303
      state: FINISHED
  ---Index Content---
      Execution time (excluding suspended state): 0.76s
      Input:
        id: 50
        contents_changed: true
        current_user_id: 3
      Output:
        {}

2. Modified the repo to remove content then re-sync'd
      step_id: 2ac3142b-b61f-47bf-9c53-e28f26ba2626
      num_processed: 1
    - num_success: 172
      description: Publishing RPMs
      step_type: rpms
      items_total: 172
      state: FINISHED
  ---Index Content---
      Execution time (excluding suspended state): 0.57s
      Input:
        id: 50
        contents_changed: true
        current_user_id: 3
      Output:
        {}

3. Made no changes to the repo and re-sync'd
      step_id: 39c1c10c-8d71-49c7-bb6b-d98aeaafbdbd
      num_processed: 1
    - num_success: 0
      description: Publishing RPMs
      step_type: rpms
      items_total: 0
      state: FINISHED
  ---Index Content---
       Execution time (excluding suspended state): 0.01s
       Input:
         id: 50
         contents_changed: false
         current_user_id: 3
       Output:
         post_sync_skipped: true
Comment 11 errata-xmlrpc 2016-12-12 12:10:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2940
Comment 12 Stephen Benjamin 2018-02-19 13:59:15 EST
*** Bug 1331378 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.