Bug 1309431 - RHEV 3.6 SSA failing
RHEV 3.6 SSA failing
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 5.6.0
Assigned To: Hui Song
Matouš Mojžíš
rhev:vm:smartstate
:
: 1328116 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 14:16 EST by Dave Johnson
Modified: 2016-06-29 11:38 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:38:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SSA scan worked for cfme 552 vm. (55.61 KB, image/png)
2016-04-27 11:50 EDT, Matouš Mojžíš
no flags Details

  None (edit)
Description Dave Johnson 2016-02-17 14:16:10 EST
Description of problem:
=============================
Running into an issue where RHEV 3.6 SSA is failing on a iscsi datastore.  This needs further investigation.


Version-Release number of selected component (if applicable):
==============================
5.5.2.4 CF
3.6.3 RHEVM


How reproducible:
====================
100%


Steps to Reproduce:
====================
1.  Manage provider
2.  configure for ssa
3.  scan vm
Comment 3 Dave Johnson 2016-02-17 14:22:14 EST
[----] E, [2016-02-17T14:14:07.565654 #27876:3d9988] ERROR -- : MIQ(ManageIQ::Providers::Redhat::InfraManager::Vm#perform_metadata_scan): undefined method `attributes' for nil:NilClass
[----] D, [2016-02-17T14:14:07.565778 #27876:3d9988] DEBUG -- : /var/www/miq/vmdb/gems/pending/MiqVm/MiqRhevmVm.rb:87:in `lun_file_path'
/var/www/miq/vmdb/gems/pending/MiqVm/MiqRhevmVm.rb:69:in `file_path_for_storage_type'
/var/www/miq/vmdb/gems/pending/MiqVm/MiqRhevmVm.rb:49:in `block in getCfg'
/var/www/miq/vmdb/gems/pending/MiqVm/MiqRhevmVm.rb:43:in `each'
/var/www/miq/vmdb/gems/pending/MiqVm/MiqRhevmVm.rb:43:in `each_with_index'
/var/www/miq/vmdb/gems/pending/MiqVm/MiqRhevmVm.rb:43:in `getCfg'
/var/www/miq/vmdb/gems/pending/MiqVm/MiqVm.rb:48:in `initialize'
/var/www/miq/vmdb/app/models/manageiq/providers/redhat/infra_manager/vm_or_template_shared/scanning.rb:16:in `new'
/var/www/miq/vmdb/app/models/manageiq/providers/redhat/infra_manager/vm_or_template_shared/scanning.rb:16:in `perform_metadata_scan'
/var/www/miq/vmdb/app/models/miq_server/server_smart_proxy.rb:123:in `scan_metadata'
/var/www/miq/vmdb/app/models/miq_queue.rb:345:in `block in deliver'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:89:in `block in timeout'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `block in catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:34:in `catch'
/opt/rh/rh-ruby22/root/usr/share/ruby/timeout.rb:104:in `timeout'
/var/www/miq/vmdb/app/models/miq_queue.rb:341:in `deliver'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:106:in `deliver_queue_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:134:in `deliver_message'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:151:in `block in do_work'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `loop'
/var/www/miq/vmdb/app/models/miq_queue_worker_base/runner.rb:145:in `do_work'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:334:in `block in do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:331:in `loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:331:in `do_work_loop'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:153:in `run'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:128:in `start'
/var/www/miq/vmdb/app/models/miq_worker/runner.rb:29:in `start_worker'
/var/www/miq/vmdb/lib/workers/bin/worker.rb:2:in `<top (required)>'
/opt/rh/cfme-gemset/gems/railties-4.2.5.1/lib/rails/commands/runner.rb:60:in `load'
/opt/rh/cfme-gemset/gems/railties-4.2.5.1/lib/rails/commands/runner.rb:60:in `<top (required)>'
/opt/rh/cfme-gemset/gems/railties-4.2.5.1/lib/rails/commands/commands_tasks.rb:123:in `require'
/opt/rh/cfme-gemset/gems/railties-4.2.5.1/lib/rails/commands/commands_tasks.rb:123:in `require_command!'
/opt/rh/cfme-gemset/gems/railties-4.2.5.1/lib/rails/commands/commands_tasks.rb:90:in `runner'
/opt/rh/cfme-gemset/gems/railties-4.2.5.1/lib/rails/commands/commands_tasks.rb:39:in `run_command!'
/opt/rh/cfme-gemset/gems/railties-4.2.5.1/lib/rails/commands.rb:17:in `<top (required)>'
/var/www/miq/vmdb/bin/rails:4:in `require'
/var/www/miq/vmdb/bin/rails:4:in `<main>'
Comment 5 Matouš Mojžíš 2016-04-25 06:27:09 EDT
*** Bug 1328116 has been marked as a duplicate of this bug. ***
Comment 7 Matouš Mojžíš 2016-04-27 11:50 EDT
Created attachment 1151461 [details]
SSA scan worked for cfme 552 vm.
Comment 9 Rich Oliveri 2016-05-10 12:05:57 EDT
*** Bug 1328116 has been marked as a duplicate of this bug. ***
Comment 10 Matouš Mojžíš 2016-05-18 08:53:03 EDT
Verified in: 5.6.0.6-beta2.5.20160511140943_ff75fb2
and RHEVM: 3.6.6.2-0.1.el6
I was able to do SSA on cfme appliance and one other vm with attached direct lun disk without storage domain.
Comment 12 errata-xmlrpc 2016-06-29 11:38:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.