Bug 1309473 - Filter chain halted as :check_privileges rendered or redirected
Filter chain halted as :check_privileges rendered or redirected
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
All All
high Severity high
: GA
: 5.6.0
Assigned To: Harpreet Kataria
Dmitry Misharov
ui:dashboard
: ZStream
Depends On:
Blocks: 1309737
  Show dependency treegraph
 
Reported: 2016-02-17 17:20 EST by Kevin Morey
Modified: 2016-07-12 02:33 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1309737 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:38:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshots (208.64 KB, application/pdf)
2016-02-17 17:20 EST, Kevin Morey
no flags Details

  None (edit)
Description Kevin Morey 2016-02-17 17:20:51 EST
Created attachment 1128024 [details]
screenshots

Description of problem:
Clicking on a vm within a dashboard widget does not correctly redirect the end user to Services / Workloads. See attached screenshots to see the errors.


Version-Release number of selected component (if applicable):
5.5.2.4

How reproducible:
100%

Steps to Reproduce:
1. Create a self-service role that only can see dashboards, services workloads but not cloud instances or infrastructure virtual machines

Actual results:
error is thrown.

Expected results:
Expecting that the user is redirected to Services / Workloads / VM Summary

Additional info:

Output from the production log:

[----] I, [2016-02-17T17:07:20.925401 #9444:110b994]  INFO -- : Started GET "/dashboard/" for 127.0.0.1 at 2016-02-17 17:07:20 -0500
[----] I, [2016-02-17T17:07:20.927531 #9444:110b994]  INFO -- : Processing by DashboardController#index as HTML
[----] I, [2016-02-17T17:07:20.972433 #9444:110b994]  INFO -- : Redirected to https://10.11.164.103/dashboard/show
[----] I, [2016-02-17T17:07:20.991083 #9444:110b994]  INFO -- : Completed 302 Found in 63ms (ActiveRecord: 3.7ms)
[----] I, [2016-02-17T17:07:21.117020 #9444:110b994]  INFO -- : Started GET "/dashboard/show" for 127.0.0.1 at 2016-02-17 17:07:21 -0500
[----] I, [2016-02-17T17:07:21.118843 #9444:110b994]  INFO -- : Processing by DashboardController#show as HTML
[----] I, [2016-02-17T17:07:21.294351 #9444:110b994]  INFO -- :   Rendered dashboard/_widget_menu.html.haml (6.6ms)
[----] I, [2016-02-17T17:07:21.294482 #9444:110b994]  INFO -- :   Rendered dashboard/_widget.html.haml (11.4ms)
[----] I, [2016-02-17T17:07:21.310403 #9444:110b994]  INFO -- :   Rendered dashboard/_widget_chart.html.haml (4.5ms)
[----] I, [2016-02-17T17:07:21.317947 #9444:110b994]  INFO -- :   Rendered dashboard/_widget_footer.html.haml (7.3ms)
[----] I, [2016-02-17T17:07:21.318064 #9444:110b994]  INFO -- :   Rendered dashboard/_widget.html.haml (21.7ms)
[----] I, [2016-02-17T17:07:21.332142 #9444:110b994]  INFO -- :   Rendered dashboard/_widget_report.html.haml (2.9ms)
[----] I, [2016-02-17T17:07:21.339242 #9444:110b994]  INFO -- :   Rendered dashboard/_widget_footer.html.haml (6.9ms)
[----] I, [2016-02-17T17:07:21.339357 #9444:110b994]  INFO -- :   Rendered dashboard/_widget.html.haml (19.3ms)
[----] I, [2016-02-17T17:07:21.353621 #9444:110b994]  INFO -- :   Rendered dashboard/_widget_report.html.haml (2.9ms)
[----] I, [2016-02-17T17:07:21.361215 #9444:110b994]  INFO -- :   Rendered dashboard/_widget_footer.html.haml (7.4ms)
[----] I, [2016-02-17T17:07:21.361339 #9444:110b994]  INFO -- :   Rendered dashboard/_widget.html.haml (20.0ms)
[----] I, [2016-02-17T17:07:21.375937 #9444:110b994]  INFO -- :   Rendered dashboard/_widget_report.html.haml (2.9ms)
[----] I, [2016-02-17T17:07:21.383330 #9444:110b994]  INFO -- :   Rendered dashboard/_widget_footer.html.haml (7.2ms)
[----] I, [2016-02-17T17:07:21.383454 #9444:110b994]  INFO -- :   Rendered dashboard/_widget.html.haml (20.1ms)
[----] I, [2016-02-17T17:07:21.397841 #9444:110b994]  INFO -- :   Rendered dashboard/_widget_report.html.haml (2.9ms)
[----] I, [2016-02-17T17:07:21.406628 #9444:110b994]  INFO -- :   Rendered dashboard/_widget_footer.html.haml (8.6ms)
[----] I, [2016-02-17T17:07:21.406761 #9444:110b994]  INFO -- :   Rendered dashboard/_widget.html.haml (21.2ms)
[----] I, [2016-02-17T17:07:21.420809 #9444:110b994]  INFO -- :   Rendered dashboard/_widget_report.html.haml (2.9ms)
[----] I, [2016-02-17T17:07:21.428289 #9444:110b994]  INFO -- :   Rendered dashboard/_widget_footer.html.haml (7.3ms)
[----] I, [2016-02-17T17:07:21.428414 #9444:110b994]  INFO -- :   Rendered dashboard/_widget.html.haml (19.7ms)
[----] I, [2016-02-17T17:07:21.447709 #9444:110b994]  INFO -- :   Rendered dashboard/show.html.haml within layouts/application (166.5ms)
[----] I, [2016-02-17T17:07:21.448056 #9444:110b994]  INFO -- :   Rendered layouts/_doctype.html.haml (0.0ms)
[----] I, [2016-02-17T17:07:21.451345 #9444:110b994]  INFO -- :   Rendered stylesheets/_template50.html.haml (0.1ms)
[----] I, [2016-02-17T17:07:21.456917 #9444:110b994]  INFO -- :   Rendered layouts/_user_options.html.haml (4.7ms)
[----] I, [2016-02-17T17:07:21.653158 #9444:110b994]  INFO -- :   Rendered layouts/_page_header_navbar.html.haml (196.0ms)
[----] I, [2016-02-17T17:07:21.653423 #9444:110b994]  INFO -- :   Rendered layouts/_spinner.html.haml (0.0ms)
[----] I, [2016-02-17T17:07:21.653680 #9444:110b994]  INFO -- :   Rendered layouts/_lightbox_panel.html.haml (0.1ms)
[----] I, [2016-02-17T17:07:21.653814 #9444:110b994]  INFO -- :   Rendered layouts/_header.html.haml (201.8ms)
[----] I, [2016-02-17T17:07:21.654618 #9444:110b994]  INFO -- :   Rendered dashboard/_widgets_menu.html.haml (0.3ms)
[----] I, [2016-02-17T17:07:21.654767 #9444:110b994]  INFO -- :   Rendered dashboard/_dropdownbar.html.haml (0.6ms)
[----] I, [2016-02-17T17:07:21.655029 #9444:110b994]  INFO -- :   Rendered layouts/_tabs.html.haml (0.1ms)
[----] I, [2016-02-17T17:07:21.655227 #9444:110b994]  INFO -- :   Rendered layouts/_content.html.haml (1.2ms)
[----] I, [2016-02-17T17:07:21.655603 #9444:110b994]  INFO -- :   Rendered layouts/_adv_search.html.haml (0.1ms)
[----] I, [2016-02-17T17:07:21.655753 #9444:110b994]  INFO -- :   Rendered layouts/_footer.html.haml (0.3ms)
[----] I, [2016-02-17T17:07:21.662585 #9444:110b994]  INFO -- : Completed 200 OK in 544ms (Views: 347.6ms | ActiveRecord: 36.6ms)
[----] I, [2016-02-17T17:07:24.779854 #9444:110b994]  INFO -- : Started GET "/vm/show/360000000000652" for 127.0.0.1 at 2016-02-17 17:07:24 -0500
[----] I, [2016-02-17T17:07:24.875417 #9444:110b994]  INFO -- : Processing by VmController#show as HTML
[----] I, [2016-02-17T17:07:24.875546 #9444:110b994]  INFO -- :   Parameters: {"id"=>"360000000000652"}
[----] I, [2016-02-17T17:07:24.942016 #9444:110b994]  INFO -- : Redirected to https://10.11.164.103/vm_cloud/explorer
[----] I, [2016-02-17T17:07:24.948601 #9444:110b994]  INFO -- : Completed 302 Found in 73ms (ActiveRecord: 23.1ms)
[----] I, [2016-02-17T17:07:25.070255 #9444:110b994]  INFO -- : Started GET "/vm_cloud/explorer" for 127.0.0.1 at 2016-02-17 17:07:25 -0500
[----] I, [2016-02-17T17:07:25.072959 #9444:110b994]  INFO -- : Processing by VmCloudController#explorer as HTML
[----] I, [2016-02-17T17:07:25.111688 #9444:110b994]  INFO -- : Redirected to https://10.11.164.103/dashboard/auth_error
[----] I, [2016-02-17T17:07:25.142638 #9444:110b994]  INFO -- : Filter chain halted as :check_privileges rendered or redirected
[----] I, [2016-02-17T17:07:25.142870 #9444:110b994]  INFO -- : Completed 302 Found in 70ms (ActiveRecord: 7.4ms)
[----] I, [2016-02-17T17:07:25.312111 #9444:110b994]  INFO -- : Started GET "/dashboard/auth_error" for 127.0.0.1 at 2016-02-17 17:07:25 -0500
[----] I, [2016-02-17T17:07:25.314688 #9444:110b994]  INFO -- : Processing by DashboardController#auth_error as HTML
[----] I, [2016-02-17T17:07:25.344446 #9444:110b994]  INFO -- :   Rendered layouts/_flash_msg.html.haml (0.2ms)
[----] I, [2016-02-17T17:07:25.344583 #9444:110b994]  INFO -- :   Rendered dashboard/auth_error.html.haml within layouts/application (0.5ms)
[----] I, [2016-02-17T17:07:25.344879 #9444:110b994]  INFO -- :   Rendered layouts/_doctype.html.haml (0.0ms)
[----] I, [2016-02-17T17:07:25.348428 #9444:110b994]  INFO -- :   Rendered stylesheets/_template50.html.haml (0.1ms)
[----] I, [2016-02-17T17:07:25.354111 #9444:110b994]  INFO -- :   Rendered layouts/_user_options.html.haml (4.8ms)
[----] I, [2016-02-17T17:07:25.551035 #9444:110b994]  INFO -- :   Rendered layouts/_page_header_navbar.html.haml (196.7ms)
[----] I, [2016-02-17T17:07:25.551383 #9444:110b994]  INFO -- :   Rendered layouts/_spinner.html.haml (0.1ms)
[----] I, [2016-02-17T17:07:25.551662 #9444:110b994]  INFO -- :   Rendered layouts/_lightbox_panel.html.haml (0.1ms)
[----] I, [2016-02-17T17:07:25.551794 #9444:110b994]  INFO -- :   Rendered layouts/_header.html.haml (202.7ms)
[----] I, [2016-02-17T17:07:25.552473 #9444:110b994]  INFO -- :   Rendered layouts/_center_buttons.html.haml (0.1ms)
[----] I, [2016-02-17T17:07:25.552738 #9444:110b994]  INFO -- :   Rendered layouts/_x_custom_buttons.html.haml (0.1ms)
[----] I, [2016-02-17T17:07:25.552994 #9444:110b994]  INFO -- :   Rendered layouts/_view_buttons.html.haml (0.1ms)
[----] I, [2016-02-17T17:07:25.553552 #9444:110b994]  INFO -- :   Rendered layouts/_taskbar.html.haml (1.3ms)
[----] I, [2016-02-17T17:07:25.553830 #9444:110b994]  INFO -- :   Rendered layouts/_breadcrumbs.html.haml (0.1ms)
[----] I, [2016-02-17T17:07:25.554099 #9444:110b994]  INFO -- :   Rendered layouts/_searchbar.html.haml (0.1ms)
[----] I, [2016-02-17T17:07:25.554400 #9444:110b994]  INFO -- :   Rendered layouts/_listnav.html.haml (0.1ms)
[----] I, [2016-02-17T17:07:25.554538 #9444:110b994]  INFO -- :   Rendered layouts/_content.html.haml (2.5ms)
[----] I, [2016-02-17T17:07:25.554932 #9444:110b994]  INFO -- :   Rendered layouts/_adv_search.html.haml (0.1ms)
[----] I, [2016-02-17T17:07:25.555082 #9444:110b994]  INFO -- :   Rendered layouts/_footer.html.haml (0.3ms)
[----] I, [2016-02-17T17:07:25.562225 #9444:110b994]  INFO -- : Completed 200 OK in 247ms (Views: 205.7ms | ActiveRecord: 10.5ms)
Comment 4 CFME Bot 2016-02-26 10:45:36 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/2352bb7936957ac5566e8c0d08cef6e41326c6ea

commit 2352bb7936957ac5566e8c0d08cef6e41326c6ea
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Feb 22 14:21:54 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Feb 22 15:03:59 2016 -0500

    Redirect user to appropriate screen when rbac access is not allowed.
    
    When clicking on a link to go to a VM summary screen from dashboard widgets redirect user to Workloads explorer when user is not allowed to see Infrastructure/Virtual Machines or Cloud/Instances explorer based upon record type. Redirect user back to Dashboard with a flash message when user does not have access to any of the VM accordions in VM* explorers.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1309473
    https://bugzilla.redhat.com/show_bug.cgi?id=1309737

 app/controllers/vm_common.rb       | 28 ++++++++++++++++++++++++++--
 app/views/dashboard/show.html.haml |  1 +
 spec/controllers/vm_common_spec.rb | 36 ++++++++++++++++++++++++++++++++++++
 3 files changed, 63 insertions(+), 2 deletions(-)
Comment 5 CFME Bot 2016-02-29 09:41:03 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=1b19cfa424671588590eef59b43825c82e243634

commit 1b19cfa424671588590eef59b43825c82e243634
Merge: f91c73d 1659678
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Feb 29 09:37:43 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Feb 29 09:37:43 2016 -0500

    Merge branch '55z_pr_6864' into '5.5.z'
    
    Redirect user to appropriate screen when rbac access is not allowed.
    
    When clicking on a link to go to a VM summary screen from dashboard widgets redirect user to Workloads explorer when user is not allowed to see Infrastructure/Virtual Machines or Cloud/Instances explorer based upon record type. Redirect user back to Dashboard with a flash message when user does not have access to any of the VM accordions in VM* explorers.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1309473
    https://bugzilla.redhat.com/show_bug.cgi?id=1309737
    (cherry picked from commit 2352bb7)
    
    @dclarizi please review/merge, this is clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/6864
    
    See merge request !822

 app/controllers/vm_common.rb       | 28 ++++++++++++++++++++++++++--
 app/views/dashboard/show.html.haml |  1 +
 spec/controllers/vm_common_spec.rb | 29 +++++++++++++++++++++++++++++
 3 files changed, 56 insertions(+), 2 deletions(-)
Comment 6 CFME Bot 2016-02-29 09:41:16 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=1659678441549b179e4f47dee6b2901d0d1857ef

commit 1659678441549b179e4f47dee6b2901d0d1857ef
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Feb 22 14:21:54 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Feb 26 19:00:08 2016 -0500

    Redirect user to appropriate screen when rbac access is not allowed.
    
    When clicking on a link to go to a VM summary screen from dashboard widgets redirect user to Workloads explorer when user is not allowed to see Infrastructure/Virtual Machines or Cloud/Instances explorer based upon record type. Redirect user back to Dashboard with a flash message when user does not have access to any of the VM accordions in VM* explorers.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1309473
    https://bugzilla.redhat.com/show_bug.cgi?id=1309737
    (cherry picked from commit 2352bb7)

 app/controllers/vm_common.rb       | 28 ++++++++++++++++++++++++++--
 app/views/dashboard/show.html.haml |  1 +
 spec/controllers/vm_common_spec.rb | 29 +++++++++++++++++++++++++++++
 3 files changed, 56 insertions(+), 2 deletions(-)
Comment 14 Dmitry Misharov 2016-04-18 09:41:40 EDT
Verified fixed in 5.6.0.1-beta2.20160413141124_e25ac0e.
Comment 16 errata-xmlrpc 2016-06-29 11:38:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.