Bug 1309486 - Got an error attempting to delete a product
Got an error attempting to delete a product
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
Unspecified
x86_64 Linux
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-17 18:42 EST by mharris
Modified: 2016-08-31 17:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-31 17:40:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of foreman-debug (3.35 MB, application/x-xz)
2016-02-17 18:42 EST, mharris
no flags Details

  None (edit)
Description mharris 2016-02-17 18:42:59 EST
Created attachment 1128059 [details]
Output of foreman-debug

Description of problem:

We created a temporary product, and followed that by creating a temporary repository, as I was explaining the use of each to the customer, specifically for the purpose of using puppet modules.

Version-Release number of selected component (if applicable):
satellite 6.1.7

How reproducible:
Unable to test in mass as customer is attempting to setup new satellite server.

Steps to Reproduce:
1. Create new product
2. Create a puppet repo (I was syncing to localhost: file:///modules/)
3. Delete repo (after a full and successful sync)
4. Delete Product (Not assigned to any content views)

Actual results:
Unable to delete product, as /etc/puppet/environments/K{whatever is specific to this product} was already deleted, which it WAS.

Expected results:
Remove the product from Foreman.

Additional info:
Ended up manually deleting row from database, using katello-rake
Comment 1 Bryan Kearney 2016-07-26 15:04:35 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 2 Brad Buckingham 2016-08-31 17:40:37 EDT
I was unable to reproduce the behavior described with Satellite 6.2.1.  I am going to close the bugzilla; however, please re-open if you see it after upgrading.

Note You need to log in before you can comment on or make changes to this bug.