Bug 1309535 - clang -print-file-name=include fails
clang -print-file-name=include fails
Status: CLOSED DUPLICATE of bug 1309055
Product: Fedora
Classification: Fedora
Component: clang (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1309295
  Show dependency treegraph
 
Reported: 2016-02-17 23:18 EST by Mattias Ellert
Modified: 2016-02-18 02:34 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 02:34:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2016-02-17 23:18:39 EST
Description of problem:

$ clang -print-file-name=include
: CommandLine Error: Option 'track-memory' registered more than once!
LLVM ERROR: inconsistency in registered CommandLine options

Version-Release number of selected component (if applicable):

$ rpm -q clang
clang-3.7.1-4.fc24.x86_64

How reproducible:

Always

Steps to Reproduce:
1. clang -print-file-name=include

Actual results:

Error

Expected results:

Similar to what clang returns on F23 (but with slightly diffrent paths obviously):

$ clang -print-file-name=include
/usr/bin/../lib/clang/3.7.0/include
$ rpm -q clang
clang-3.7.0-4.fc23.x86_64

Additional info:

This is a recent regression - llvm.x86_64 3.7.1-1.fc24 did work - so it was working on F24 before. Something happened since then.
Comment 1 Mattias Ellert 2016-02-17 23:46:35 EST
clang has its own component in F24. Reassigning.
Comment 2 Petr Pisar 2016-02-18 02:34:33 EST

*** This bug has been marked as a duplicate of bug 1309055 ***

Note You need to log in before you can comment on or make changes to this bug.