Bug 130954 - gamin 0.0.7 not seeing all the fstab changes
gamin 0.0.7 not seeing all the fstab changes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-25 21:36 EDT by Jef Spaleta
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 04:55:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2004-08-25 21:36:29 EDT
Description of problem:
gam_server doesn't seem to more than the initial change in fstab
when im (un)plugging usb devices.

hal and udev seem to be working just fine the /etc/fstab file
is updated when i plug and unplug usb devices.

But to get the devices to show or disappear in nautilus Computer view
I have to kill gam_server. gam_server immediately restarts and
nautilus updates with the newest view.

Version-Release number of selected component (if applicable):
0.0.7-1

How reproducible:
Everything but the initial plugin of the first usb device is not seen.

Steps to Reproduce:
1. plugin usb keydrive
2. watch it appear in nautilus Computer window
3. mount it, create the "i_love_meatballs.xcf" in the gimp
4. unmount the usbdisk
5. watch in horror as nautilus continues to show this device in its
listing
6.killall gam_server
7. watch the device disappear from Computer view, and put on your
saddest clown makeup.

  
Expected results:
auto updating of the icons in Computer when i unplug the device.


Additional info:
I am rawhide synced except for hal. I am using
hal-0.2.97.cvs20040819-1  since hal-0.2.97.cvs20040823-1
is having issues daemonizing and the hal to fix that didnt show up in
rawhide today :-<.  But like i said the /etc/fstab entry and the
associated /media/ mountpoints are updating like i expect so i dont
think its hal, i think its gamin 0.0.7.

Am I hitting the "feature" you talked about in your blog?


-jef
Comment 1 Daniel Veillard 2004-08-26 04:47:56 EDT
What lead you to believe that gam_server is used to watch 
/etc/fstab ? This contradict my understanding of the issue
(which is that you have a lazy umount which doesn't finish
due to the persistant open led by dnotify.

Your report is confusing:
  "to get the devices to show or disappear in nautilus Computer view
   I have to kill gam_server."
and in the step to reproduce between 1 and 2 you don't kill 
gam_server so it does show without killing it, right ?

What is the mount point used for your USB key ? I do not have the
hardware to reproduce this.

Daniel
Comment 2 Jef Spaleta 2004-08-26 08:19:57 EDT
"What lead you to believe that gam_server is used to watch 
/etc/fstab"

I honestly don't how the magic works specifically.

My first sentence, while being very bad english, was meant to clarify
that the first device that i plug in, gets seen in Computer and only
the first device I plugin. No plugin or unplug after that gets noticed
by the Computer window, even though fstab and the /media/ mountpoints
are updated.

But anything else i do after that, until i forcible kill gam_server
doesn't produce an update in the Computer window,

Mount point for the usb key is /media/usbdisk1

another scenario
1) i plugin a usb keydrive fstab updates and then Compyuter window
updates  mountpoint /media/usbdisk1
2) i plugin a flash card into my flash card reader fstab updates but
the Computer window doesn't  mountpoint /media/usbdisk
3)I kill gam_server   and now both usbdrive and usbdrive1 icons are
present in Computer.

If there are specific things you would like me to log, I'd greatly
appreciate some pointers on how to squeeze more information out of my
system as to whats going on. 

Though I can't get back to testing this box for a couple of days.
Comment 3 Daniel Veillard 2004-08-26 11:50:35 EDT
I just pushed gamin-0.0.8 it would be interesting to see if this
still break :
http://www.gnome.org/~veillard/gamin/downloads.html
grab the src.rpm and recompile or wait for the rawhide update

Daniel
Comment 4 Jef Spaleta 2004-08-27 19:42:50 EDT
Okay, gamin-0.0.8 seems to have fixed this issue. 
When hal actually works for me... and updates the mountpoints for the
usb devices correctly.. the nautilus Computer window updates
accordingly. In fact I can hand edit the /etc/fstab file now and had
user mountable entries and the Computer window uppdates with the new
entries.  Unless I hear otherwise from you, I'll close this bug report
tomorrow morning. 

-jef
Comment 5 Daniel Veillard 2004-09-01 04:55:39 EDT
Okay, closed in RawHide,

 thanks,

Daniel
Comment 6 Julien Olivier 2004-09-03 07:08:46 EDT
I still see the proble with gamin-0.0.8, but only from time to time.

Note You need to log in before you can comment on or make changes to this bug.