Bug 1309555 - Crash in Xorg server due to VIA P4M900 chipset and OpenChrome driver
Crash in Xorg server due to VIA P4M900 chipset and OpenChrome driver
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
23
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 01:03 EST by Jeffrey Walton
Modified: 2016-04-26 17:21 EDT (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-drv-openchrome-0.4.0-1.fc24 xorg-x11-drv-openchrome-0.4.0-1.fc23 xorg-x11-drv-openchrome-0.4.0-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-18 13:25:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 92711 None None None 2016-02-18 01:12 EST
FreeDesktop.org 94130 None None None 2016-02-18 01:11 EST
Launchpad 1540774 None None None 2016-02-18 01:10 EST
Debian BTS 814682 None None None 2016-02-18 01:09 EST

  None (edit)
Description Jeffrey Walton 2016-02-18 01:03:02 EST
I've attempted to load Fedora 22,23 and upcoming 24 on a machine with a VIA C7-D processor and P4M900 chipset. I can barely get the machine to boot. When using a Live CD, output hangs before any text is output to the screen. I've never been able to do anything with Fedora on this machine.

Using Debian and Ubuntu, we tracked the issue down to the OpenChrome driver. The OpenChrome driver crashes due to a NULL pointer dereference. A log under Debian is shown below:

  [ 495.699] (EE) 8: /usr/bin/X (0x80035000+0x2bdd8) [0x80060dd8]
  [ 495.701] (EE) Segmentation fault at address 0x0
  [ 495.701] (EE) Fatal server error:
  [ 495.702] (EE) Caught signal 11 (Segmentation fault). Server aborting

We filed a bug report with the folks at Freedesktop.org [1]. Kevin Brace of Freedesktop was aware of the issue. He committed the fix and published instructions for testing the fix [2].

We tested the fix tonight, and it cleared the issue under Debian and Ubuntu [3]. Fedora's LiveCD's are still dead, so we could not test under them.

I strongly encourage Fedora to pickup the latest OpenChrome driver.

[1] http://bugs.freedesktop.org/show_bug.cgi?id=94130
[2] http://lists.freedesktop.org/archives/openchrome-devel/2016-February/001753.html
[3] http://bugs.freedesktop.org/show_bug.cgi?id=94130#c4

==========

via:~$ cat /var/log/Xorg.0.log
[   495.454] 
X.Org X Server 1.17.2
Release Date: 2015-06-16
[   495.455] X Protocol Version 11, Revision 0
[   495.455] Build Operating System: Linux 3.13.0-68-generic i686 Ubuntu
[   495.456] Current Operating System: Linux via 4.2.0-27-generic #32-Ubuntu SMP Fri Jan 22 04:48:15 UTC 2016 i686
[   495.456] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.2.0-27-generic root=UUID=cfc626dc-ce95-48e1-a8c8-98c258e77415 ro ipv6.disable=1 biosdevname=0 longhaul.enable=0 audit=0 splash vt.handoff=7
[   495.458] Build Date: 12 November 2015  05:33:32PM
[   495.459] xorg-server 2:1.17.2-1ubuntu9.1 (For technical support please see http://www.ubuntu.com/support) 
[   495.459] Current version of pixman: 0.32.6
[   495.460] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   495.460] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   495.462] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Feb 12 22:57:45 2016
[   495.463] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   495.464] (==) No Layout section.  Using the first Screen section.
[   495.465] (==) No screen section available. Using defaults.
[   495.465] (**) |-->Screen "Default Screen Section" (0)
[   495.465] (**) |   |-->Monitor "<default monitor>"
[   495.465] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[   495.465] (==) Automatically adding devices
[   495.465] (==) Automatically enabling devices
[   495.465] (==) Automatically adding GPU devices
[   495.465] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   495.465] 	Entry deleted from font path.
[   495.465] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   495.465] 	Entry deleted from font path.
[   495.465] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   495.465] 	Entry deleted from font path.
[   495.465] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
[   495.465] 	Entry deleted from font path.
[   495.465] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   495.465] 	Entry deleted from font path.
[   495.465] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   495.465] 	Entry deleted from font path.
[   495.465] (==) FontPath set to:
	/usr/share/fonts/X11/misc,
	built-ins
[   495.466] (==) ModulePath set to "/usr/lib/i386-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[   495.466] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   495.466] (II) Loader magic: 0x8029c6c0
[   495.466] (II) Module ABI versions:
[   495.466] 	X.Org ANSI C Emulation: 0.4
[   495.466] 	X.Org Video Driver: 19.0
[   495.466] 	X.Org XInput driver : 21.0
[   495.466] 	X.Org Server Extension : 9.0
[   495.468] (--) PCI:*(0:1:0:0) 1106:3371:1019:2125 rev 1, Mem @ 0xd0000000/268435456, 0xfd000000/16777216, BIOS @ 0x????????/65536
[   495.468] (II) LoadModule: "glx"
[   495.469] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   495.472] (II) Module glx: vendor="X.Org Foundation"
[   495.472] 	compiled for 1.17.2, module version = 1.0.0
[   495.472] 	ABI class: X.Org Server Extension, version 9.0
[   495.473] (==) AIGLX enabled
[   495.473] (==) Matched openchrome as autoconfigured driver 0
[   495.473] (==) Matched modesetting as autoconfigured driver 1
[   495.473] (==) Matched fbdev as autoconfigured driver 2
[   495.473] (==) Matched vesa as autoconfigured driver 3
[   495.473] (==) Assigned the driver to the xf86ConfigLayout
[   495.473] (II) LoadModule: "openchrome"
[   495.473] (II) Loading /usr/lib/xorg/modules/drivers/openchrome_drv.so
[   495.474] (II) Module openchrome: vendor="http://openchrome.org/"
[   495.474] 	compiled for 1.17.1, module version = 0.3.3
[   495.474] 	Module class: X.Org Video Driver
[   495.474] 	ABI class: X.Org Video Driver, version 19.0
[   495.474] (II) LoadModule: "modesetting"
[   495.474] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   495.475] (II) Module modesetting: vendor="X.Org Foundation"
[   495.475] 	compiled for 1.17.2, module version = 1.17.2
[   495.475] 	Module class: X.Org Video Driver
[   495.475] 	ABI class: X.Org Video Driver, version 19.0
[   495.475] (II) LoadModule: "fbdev"
[   495.475] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[   495.475] (II) Module fbdev: vendor="X.Org Foundation"
[   495.476] 	compiled for 1.17.1, module version = 0.4.4
[   495.476] 	Module class: X.Org Video Driver
[   495.476] 	ABI class: X.Org Video Driver, version 19.0
[   495.476] (II) LoadModule: "vesa"
[   495.476] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[   495.477] (II) Module vesa: vendor="X.Org Foundation"
[   495.477] 	compiled for 1.17.1, module version = 2.3.4
[   495.477] 	Module class: X.Org Video Driver
[   495.477] 	ABI class: X.Org Video Driver, version 19.0
[   495.477] (II) OPENCHROME: Driver for VIA Chrome chipsets: CLE266, KM400/KN400,
	K8M800/K8N800, PM800/PM880/CN400, VM800/P4M800Pro/VN800/CN700,
	CX700/VX700, K8M890/K8N890, P4M890, P4M900/VN896/CN896, VX800/VX820,
	VX855/VX875, VX900
[   495.477] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   495.477] (II) FBDEV: driver for framebuffer: fbdev
[   495.477] (II) VESA: driver for VESA chipsets: vesa
[   495.477] (--) using VT number 2

[   495.519] (!!) VIA Technologies does not support this driver in any way.
[   495.520] (!!) For support, please refer to http://www.openchrome.org/.
[   495.520] (!!) (openchrome 0.3.3 release)
[   495.520] (WW) Falling back to old probe method for modesetting
[   495.520] (EE) open /dev/dri/card0: No such file or directory
[   495.520] (WW) Falling back to old probe method for fbdev
[   495.520] (II) Loading sub module "fbdevhw"
[   495.520] (II) LoadModule: "fbdevhw"
[   495.520] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   495.521] (II) Module fbdevhw: vendor="X.Org Foundation"
[   495.521] 	compiled for 1.17.2, module version = 0.0.2
[   495.521] 	ABI class: X.Org Video Driver, version 19.0
[   495.521] (WW) Falling back to old probe method for vesa
[   495.521] (II) CHROME(0): VIAPreInit
[   495.521] (II) CHROME(0): VIAGetRec
[   495.521] (--) CHROME(0): Chipset: P4M900/VN896/CN896
[   495.521] (--) CHROME(0): Chipset revision: 0
[   495.675] (EE) CHROME(0): [drm] Failed to open DRM device for pci:0000:01:00.0: No such file or directory
[   495.676] (II) Loading sub module "vgahw"
[   495.676] (II) LoadModule: "vgahw"
[   495.677] (II) Loading /usr/lib/xorg/modules/libvgahw.so
[   495.678] (II) Module vgahw: vendor="X.Org Foundation"
[   495.678] 	compiled for 1.17.2, module version = 0.1.0
[   495.678] 	ABI class: X.Org Video Driver, version 19.0
[   495.678] (--) CHROME(0): Probed amount of VideoRAM = 262144 kB
[   495.678] (II) CHROME(0): VIAMapMMIO
[   495.678] (--) CHROME(0): mapping MMIO @ 0xfd000000 with size 0xd000
[   495.678] (--) CHROME(0): mapping BitBlt MMIO @ 0xfd200000 with size 0x200000
[   495.679] (II) CHROME(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0
[   495.679] (II) CHROME(0): VIAMapFB
[   495.679] (--) CHROME(0): mapping framebuffer @ 0xd0000000 with size 0x10000000
[   495.685] (--) CHROME(0): Frame buffer start: 0xa6b96000, free start: 0x0 end: 0x10000000
[   495.685] (II) CHROME(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[   495.685] (==) CHROME(0): Depth 24, (--) framebuffer bpp 32
[   495.685] (==) CHROME(0): RGB weight 888
[   495.685] (==) CHROME(0): Default visual is TrueColor
[   495.685] (II) CHROME(0): VIASetupDefaultOptions - Setting up default chipset options.
[   495.685] (==) CHROME(0): Shadow framebuffer is disabled.
[   495.685] (==) CHROME(0): Hardware acceleration is enabled.
[   495.685] (==) CHROME(0): Using EXA acceleration architecture.
[   495.685] (==) CHROME(0): EXA composite acceleration enabled.
[   495.686] (==) CHROME(0): EXA scratch area size is 4096 kB.
[   495.686] (==) CHROME(0): Using hardware two-color cursors and software full-color cursors.
[   495.686] (==) CHROME(0): GPU virtual command queue will be enabled.
[   495.686] (==) CHROME(0): DRI IRQ will be enabled if DRI is enabled.
[   495.686] (==) CHROME(0): AGP DMA will be disabled if DRI is enabled.
[   495.686] (==) CHROME(0): PCI DMA will not be used for XV image transfer if DRI is enabled.
[   495.686] (==) CHROME(0): Will not enable VBE modes.
[   495.686] (==) CHROME(0): VBE VGA register save & restore will not be used
	if VBE modes are enabled.
[   495.686] (==) CHROME(0): Xv Bandwidth check is enabled.
[   495.686] (==) CHROME(0): Will not impose a limit on video RAM reserved for DRI.
[   495.686] (==) CHROME(0): Will try to allocate 32768 kB of AGP memory.
[   495.686] (==) CHROME(0): TV dotCrawl is disabled.
[   495.686] (==) CHROME(0): TV deflicker is set to 0.
[   495.686] (==) CHROME(0): No default TV type is set.
[   495.686] (==) CHROME(0): No default TV output signal type is set.
[   495.686] (==) CHROME(0): No default TV output port is set.
[   495.686] (==) CHROME(0): Will not print VGA registers.
[   495.687] (==) CHROME(0): Will not scan I2C buses.
[   495.687] (II) CHROME(0): ...Finished parsing config file options.
[   495.687] (EE) CHROME(0): Unknown Card-Ids (3371|1019|2125), Chipset: P4M900/VN896/CN896; please report to openchrome-users@lists.freedesktop.org
[   495.687] (EE) 
[   495.688] (EE) Backtrace:
[   495.690] (EE) 0: /usr/bin/X (xorg_backtrace+0x52) [0x801d80e2]
[   495.691] (EE) 1: /usr/bin/X (0x80035000+0x1a7522) [0x801dc522]
[   495.692] (EE) 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb779fbd0]
[   495.693] (EE) 3: /usr/lib/xorg/modules/drivers/openchrome_drv.so (0xb6dc1000+0x125bc) [0xb6dd35bc]
[   495.694] (EE) 4: /usr/bin/X (InitOutput+0xb89) [0x800b82e9]
[   495.696] (EE) 5: /usr/bin/X (0x80035000+0x4207f) [0x8007707f]
[   495.697] (EE) 6: /usr/bin/X (0x80035000+0x2bd9a) [0x80060d9a]
[   495.698] (EE) 7: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xde) [0xb735c72e]
[   495.699] (EE) 8: /usr/bin/X (0x80035000+0x2bdd8) [0x80060dd8]
[   495.700] (EE) 
[   495.701] (EE) Segmentation fault at address 0x0
[   495.701] (EE) 
Fatal server error:
[   495.702] (EE) Caught signal 11 (Segmentation fault). Server aborting
[   495.702] (EE) 
[   495.703] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   495.704] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   495.704] (EE) 
[   495.787] (EE) Server terminated with error (1). Closing log file.
Comment 1 Jeffrey Walton 2016-04-03 20:47:51 EDT
Now related: "OpenChrome driver 0.4.0 released" (http://bugzilla.redhat.com/show_bug.cgi?id=1323538).

Once the OpenChrome driver is updated, all the LiveCDs and LiveDVDs should probably be rebuilt because of the Xserver crash. Its very frustrating to attempt an Live install and have a crash right out of the box.
Comment 2 Fedora Update System 2016-04-13 16:46:38 EDT
xorg-x11-drv-openchrome-0.4.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-79c8dbc69c
Comment 3 Fedora Update System 2016-04-13 16:46:52 EDT
xorg-x11-drv-openchrome-0.4.0-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa649e14be
Comment 4 Fedora Update System 2016-04-13 16:47:03 EDT
xorg-x11-drv-openchrome-0.4.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-21a987a407
Comment 5 Fedora Update System 2016-04-15 04:38:01 EDT
xorg-x11-drv-openchrome-0.4.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-21a987a407
Comment 6 Fedora Update System 2016-04-16 15:26:55 EDT
xorg-x11-drv-openchrome-0.4.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-79c8dbc69c
Comment 7 Fedora Update System 2016-04-16 15:28:12 EDT
xorg-x11-drv-openchrome-0.4.0-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-aa649e14be
Comment 8 Fedora Update System 2016-04-18 13:25:51 EDT
xorg-x11-drv-openchrome-0.4.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2016-04-18 21:21:26 EDT
xorg-x11-drv-openchrome-0.4.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2016-04-26 17:21:09 EDT
xorg-x11-drv-openchrome-0.4.0-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.