Bug 1309612 - Increase RHEV Windows VM name lengths to 256 characters
Increase RHEV Windows VM name lengths to 256 characters
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.3.1
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.1.0-alpha
: ---
Assigned To: Shahar Havivi
Ilanit Stein
:
Depends On: 1308778
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 04:56 EST by Ilanit Stein
Modified: 2016-06-15 07:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-15 07:39:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mgoldboi: ovirt‑4.1?
istein: planning_ack?
istein: devel_ack?
istein: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Ilanit Stein 2016-02-18 04:56:55 EST
Description of problem:

This bug purpose is to complete the missing parts of RFE BZ 906243.

Original request was:
1. What is the nature and description of the request?
RHEV Windows VM /template names are limited to 15 characters so as to enable VM to join domain with VM as netbios name .
Customer wants this limit to increase to 256 characters .
This may also require a proper warning about failure in Sysprep when using more than 15 characters

2. Why does the customer need this? (List the business requirements here)
VMs in customers environment are usually very big as names have customer specific UUIDs .
Hence limit for a VM name is too short for customer requirement for VM names .

3. How would the customer like to achieve this? (List the functional
requirements here)
Name / Re-name VM with names larger than 15 charecters

So far, add hostname attribute for windows sysprep was implemented (within BZ 906243).

Please add these missing parts:

1. Increase the limit on VM names for both windows & non-windows VMs to 256.
2. Put a limit of 15 characters while assigning hostname attribute for windows sysprep (netbios name).

Version-Release number of selected component (if applicable):
rhevm 3.6.3-0.1
Comment 1 Michal Skrivanek 2016-02-19 00:56:28 EST
Most stuff is handled in bug 1308778
Comment 2 Moran Goldboim 2016-03-24 04:30:41 EDT
deferred to next version due to capacity.
Comment 3 Shahar Havivi 2016-06-15 07:39:27 EDT
This is already fixed in 4.0
VMs are limited to 256 characters and cut the first 15 in case of sysprep.
User also have a help sign (?) sign in sysprep name that indicate the name cutting in case of a longer then 15 character vm name.

Note You need to log in before you can comment on or make changes to this bug.