Bug 1309620 - heketi: ELF Binary/Library Stripping
heketi: ELF Binary/Library Stripping
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS Container Converged 1.0
Assigned To: Luis Pabón
Prasanth
: ZStream
Depends On:
Blocks: 1117266 1323543 1332128
  Show dependency treegraph
 
Reported: 2016-02-18 05:23 EST by Shruti Sampat
Modified: 2016-11-08 17:25 EST (History)
6 users (show)

See Also:
Fixed In Version: heketi-1.4.2-1.el7rhgs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1323543 (view as bug list)
Environment:
Last Closed: 2016-08-04 00:50:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shruti Sampat 2016-02-18 05:23:07 EST
Description of problem:
------------------------

ELF Binary/Library Stripping test fails for heketi -

BAD	 	heketi	 	File usr/bin/heketi is not stripped on x86_64
BAD	 	heketi	 	File usr/bin/heketi-cli is not stripped on x86_64

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
heketi-1.0.0-1.el6rhs
Comment 3 Luis Pabón 2016-02-18 11:43:30 EST
Interesting. I'll check how to do this.
Comment 4 Luis Pabón 2016-02-18 11:44:52 EST
It seems that the build system in Fedora is setup to do this for Golang programs, but the RHS system is not.

Isn't great to be first! >.>
Comment 5 Luis Pabón 2016-02-18 11:55:38 EST
It looks like I need to pass -ldflags "-s"  to go build for it to strip the debugging information.
Comment 7 Luis Pabón 2016-04-12 10:06:05 EDT
Fixed in heketi-1.0.2-2
Comment 13 Prasanth 2016-07-25 02:15:37 EDT
Verified as fixed in the latest brewtap run
Comment 15 errata-xmlrpc 2016-08-04 00:50:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1498.html

Note You need to log in before you can comment on or make changes to this bug.