Bug 1309625 - updated nfs-utils package broke nfsdcltrack
updated nfs-utils package broke nfsdcltrack
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils (Show other bugs)
7.2
All Linux
urgent Severity high
: rc
: ---
Assigned To: Steve Dickson
Yongcheng Yang
Marie Dolezelova
: Patch, Regression, TestCaseProvided, ZStream
Depends On: 1285097
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 05:33 EST by Libor Miksik
Modified: 2018-04-23 08:44 EDT (History)
26 users (show)

See Also:
Fixed In Version: nfs-utils-1.3.0-0.21.el7_2.1
Doc Type: Bug Fix
Doc Text:
The update of the nfs-utils packages in Red Hat Enterprise Linux 7.2 added support for the NFSv4.1 features which was incomplete. Consequently, the NFSv4 client-tracking callout program (nfsdcltrack) created an incorrect schema for the clients table, and the file locks appeared then but these locks did not persist after restart. With this update, the underlying source code has been fixed, and nfsdcltrack can now enter the NFS client data into the database. As a result, NFS clients no longer experience the incorrect locks after NFS server restart.
Story Points: ---
Clone Of: 1285097
Environment:
Last Closed: 2016-06-23 12:31:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash report (106.53 KB, text/plain)
2016-05-10 10:50 EDT, Luc Lalonde
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2065873 None None None 2016-02-18 05:33 EST

  None (edit)
Description Libor Miksik 2016-02-18 05:33:42 EST
This bug has been copied from bug #1285097 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 5 Steve Dickson 2016-04-26 14:10:46 EDT
 nfs-utils-1.3.0-0.21.el7_2 already exists... so I really don't know what to do to get this in the errata...
Comment 6 Steve Dickson 2016-05-03 11:56:32 EDT
I've done the commit
commit e3cd958a42458fdb5fdd24d15b052ca4d034965c
Author: Steve Dickson <steved@redhat.com>
Date:   Mon Feb 22 16:58:21 2016 -0500

    Update to nfsdcltrack v2 schema (bz 1309625)
    
    Signed-off-by: Steve Dickson <steved@redhat.com>
    Resolves: bz1309625

But the NVR does not increase from _2 to _3 
so the build fails with:

rhpkg build
Could not execute build: Package nfs-utils-1.3.0-0.21.el7_2 has already been built
Note: You can skip this check with --skip-nvr-check. See help for more info.
make: *** [build] Error 1
Comment 7 Jason Harper 2016-05-03 12:43:11 EDT
I'm a bit confused.  This bug is marked "Fixed In Version: nfs-utils-1.3.0-0.21.el7_2" but advisory RHBA-2016:0206-1does not mention that it includes the fix for this issue.  Is it fixed in nfs-utils-1.3.0-0.21.el7_2 or not?  If not, why is this bug marked that it is?
Comment 8 Marcel Kolaja 2016-05-04 12:00:41 EDT
(In reply to Steve Dickson from comment #6)
> I've done the commit
> commit e3cd958a42458fdb5fdd24d15b052ca4d034965c
> Author: Steve Dickson <steved@redhat.com>
> Date:   Mon Feb 22 16:58:21 2016 -0500
> 
>     Update to nfsdcltrack v2 schema (bz 1309625)
>     
>     Signed-off-by: Steve Dickson <steved@redhat.com>
>     Resolves: bz1309625
> 
> But the NVR does not increase from _2 to _3 
> so the build fails with:
> 
> rhpkg build
> Could not execute build: Package nfs-utils-1.3.0-0.21.el7_2 has already been
> built
> Note: You can skip this check with --skip-nvr-check. See help for more info.
> make: *** [build] Error 1

As in bug #1325769, I suspect that the Release in the spec file needs to be incremented. Could that be the problem, Steve? Thanks!
Comment 9 Steve Dickson 2016-05-04 17:36:48 EDT
Again, how do I update the Release: to make this happen?
Comment 10 Marcel Kolaja 2016-05-06 07:57:03 EDT
(In reply to Steve Dickson from comment #9)
> Again, how do I update the Release: to make this happen?

I _think_ it should be:

Release: 0.22%{?dist}

Or anything that fits your versioning scheme. Does it make sense this way?
Comment 11 Steve Dickson 2016-05-06 09:34:12 EDT
(In reply to Marcel Kolaja from comment #10)
> (In reply to Steve Dickson from comment #9)
> > Again, how do I update the Release: to make this happen?
> 
> I _think_ it should be:
> 
> Release: 0.22%{?dist}
> 
> Or anything that fits your versioning scheme. Does it make sense this way?

As I said in the othr bz... the original released NVR has to be persevere
THe _# is Z-stream version.
Comment 12 Marcel Kolaja 2016-05-09 10:21:36 EDT
(In reply to Steve Dickson from comment #11)
> (In reply to Marcel Kolaja from comment #10)
> > (In reply to Steve Dickson from comment #9)
> > > Again, how do I update the Release: to make this happen?
> > 
> > I _think_ it should be:
> > 
> > Release: 0.22%{?dist}
> > 
> > Or anything that fits your versioning scheme. Does it make sense this way?
> 
> As I said in the othr bz... the original released NVR has to be persevere
> THe _# is Z-stream version.

Similarly as in the other bug, yes, it's shouldn't be 0.22%{?dist}. Sorry for that. Does this work?

Release: 0.21%{?dist}.1
Comment 13 Luc Lalonde 2016-05-10 10:47:23 EDT
This is not fixed... I'm still getting the error with nfs-utils-1.3.0-0.21.el7_2:

May 10 10:44:51 nfs4-server nfsdcltrack[29235]: sqlite_insert_client: insert statement prepare failed: table clients has 2 columns but 3 values were supplied

I'm also wondering if it's related to an ABRT crash report I've recently received.  I'll post the report as an attachment.
Comment 14 Luc Lalonde 2016-05-10 10:50 EDT
Created attachment 1155774 [details]
Crash report

I don't know if this is related to this issue...
Comment 17 Yongcheng Yang 2016-05-18 23:05:43 EDT
Move to VERIFIED according to comment 16
Comment 19 errata-xmlrpc 2016-06-23 12:31:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1258

Note You need to log in before you can comment on or make changes to this bug.