Bug 1309626 - [RFE]: [GSS] - Feature Request (RFE) to force a volume to use a specified port
[RFE]: [GSS] - Feature Request (RFE) to force a volume to use a specified port
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
3.1
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Atin Mukherjee
storage-qa-internal@redhat.com
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 05:34 EST by Mukul Malhotra
Modified: 2016-09-17 12:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-22 02:56:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mukul Malhotra 2016-02-18 05:34:08 EST
Description of problem:

This is a feature request (RFE) to force a volume to use a specified port manually as currently this feature does not exist.

For example:

# gluster volume <Volume_Name> force <Port_Number>

Thanks
Mukul
Comment 1 Atin Mukherjee 2016-02-19 07:05:40 EST
Why is that need, can you please elaborate?
Comment 2 Mukul Malhotra 2016-02-19 10:17:15 EST
Hello Atin,

Actually, customer' setup is behind the firewall so due to change in brick port in https://bugzilla.redhat.com/show_bug.cgi?id=1306656, customer have to open multiple port in firewall so Its a customer's requirement to force a specific brick port.

Mukul
Comment 3 Atin Mukherjee 2016-02-21 23:01:55 EST
Mukul,

But what happens if we fix 1306656? Does this requirement still hold true here?

~Atin
Comment 4 Atin Mukherjee 2016-02-21 23:38:45 EST
OTOH, 3.1.1 onwards we have also defined the firewalld rules for opening up the ports for RHGS. In that case brick ports ranging from 49152 to 49664 are already opened up.
Comment 6 Atin Mukherjee 2016-02-22 06:37:51 EST
Based on #c5 lowering down the priority and severity.
Comment 7 Cal Calhoun 2016-03-17 11:54:21 EDT
A customer has asked about the feasibility of having new bricks re-use previously freed ports before grabbing new ones.  Is that in the realm of this potential RFE or better for a new one?
Comment 8 Atin Mukherjee 2016-03-29 06:05:53 EDT
(In reply to Cal Calhoun from comment #7)
> A customer has asked about the feasibility of having new bricks re-use
> previously freed ports before grabbing new ones.  Is that in the realm of
> this potential RFE or better for a new one?

We've started working on that, an upstream patch http://review.gluster.org/#/c/10785/ is posted for review. But I am still not convinced about this requirement where a dedicated port will be given to a specific volume. Does it really make sense?
Comment 9 Cal Calhoun 2016-03-30 13:09:11 EDT
(In reply to Atin Mukherjee from comment #8)
> (In reply to Cal Calhoun from comment #7)
> > A customer has asked about the feasibility of having new bricks re-use
> > previously freed ports before grabbing new ones.  Is that in the realm of
> > this potential RFE or better for a new one?
> 
> We've started working on that, an upstream patch
> http://review.gluster.org/#/c/10785/ is posted for review. But I am still
> not convinced about this requirement where a dedicated port will be given to
> a specific volume. Does it really make sense?

I think the only reason it applies is so that gluster behaves in a predictable way, by reusing resources rather than grabbing new ones.  I think this specific customer will be satisfied with assigning his ports directly but having ports re-used automatically might save some issues in the future.
Comment 10 Atin Mukherjee 2016-04-19 09:30:01 EDT
(In reply to Cal Calhoun from comment #9)
> (In reply to Atin Mukherjee from comment #8)
> > (In reply to Cal Calhoun from comment #7)
> > > A customer has asked about the feasibility of having new bricks re-use
> > > previously freed ports before grabbing new ones.  Is that in the realm of
> > > this potential RFE or better for a new one?
> > 
> > We've started working on that, an upstream patch
> > http://review.gluster.org/#/c/10785/ is posted for review. But I am still
> > not convinced about this requirement where a dedicated port will be given to
> > a specific volume. Does it really make sense?
> 
> I think the only reason it applies is so that gluster behaves in a
> predictable way, by reusing resources rather than grabbing new ones.  I
> think this specific customer will be satisfied with assigning his ports
> directly but having ports re-used automatically might save some issues in
> the future.

Agreed, but the intention of this bug is different IMO and I don't think that's feasible. IIUC, the request is to use a specific port for a particular brick process which I don't think we can do here.
Comment 11 Atin Mukherjee 2016-04-19 11:25:52 EDT
Mukul,

We wouldn't be able to meet this requirement since that will introduce some definite problems into the code.

-Atin
Comment 12 Atin Mukherjee 2016-07-19 01:47:12 EDT
Alok,

Dev doesn't think this feature to be a feasible one. What's your take on this?

~Atin
Comment 16 Mukul Malhotra 2016-08-22 02:56:11 EDT
Atin,

As per comment 13 & 14, closing the bz.

Mukul

Note You need to log in before you can comment on or make changes to this bug.