Bug 1309630 - ff45 won't build due to hardcoded 38 version
ff45 won't build due to hardcoded 38 version
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firefox (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Stransky
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 05:43 EST by Tomas Pelka
Modified: 2016-02-19 14:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-19 14:04:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2016-02-18 05:43:08 EST
Description of problem:
rpm-build fail due to probably hardcoded version 38 in path

see snipped build log
--
88947-+ ln -s /usr/share/myspell /home/test/rpmbuild/BUILDROOT/firefox-45.0-0.10.el7_2.x86_64/usr/lib64/firefox/dictionaries
88948-+ rm -rf '/usr/lib/debug/lib/firefox-devel-*'
88949-+ rm -rf /usr/lib/debug/lib64/firefox-devel-38.6.0
88950-rm: cannot remove '/usr/lib/debug/lib64/firefox-devel-38.6.0/sdk/lib/libxul.so.debug': Permission denied
88951-rm: cannot remove '/usr/lib/debug/lib64/firefox-devel-38.6.0/sdk/lib/libmozalloc.so.debug': Permission denied
88952:error: Bad exit status from /var/tmp/rpm-tmp.YBIaGO (%install)

Version-Release number of selected component (if applicable):


How reproducible:
firefox-45.0-0.10.el7_2

Steps to Reproduce:
1. rebuild ff from source
2.
3.

Actual results:


Expected results:
should build

Additional info:
Comment 2 Martin Stransky 2016-02-19 10:14:02 EST
Can you please attach a full build log? Mine looks like:

/home/komat/rpmbuild/BUILD/firefox-45.0/firefox-45.0b5
+ echo '%lang(zh) /usr/lib64/firefox/langpacks/langpack-zh@firefox.mozilla.org.xpi'
+ /usr/bin/mkdir -p /home/komat/rpmbuild/BUILDROOT/firefox-45.0-0.10.el7.x86_64//usr/lib64/firefox/defaults/preferences
+ /usr/bin/mkdir -p /home/komat/rpmbuild/BUILDROOT/firefox-45.0-0.10.el7.x86_64//usr/lib64/firefox/browser/defaults
+ ln -s /usr/lib64/firefox/defaults/preferences /home/komat/rpmbuild/BUILDROOT/firefox-45.0-0.10.el7.x86_64//usr/lib64/firefox/browser/defaults/preferences
+ /usr/bin/cp /home/komat/rpmbuild/SOURCES/firefox-redhat-default-prefs.js /home/komat/rpmbuild/BUILDROOT/firefox-45.0-0.10.el7.x86_64/usr/lib64/firefox/defaults/preferences/all-redhat.js
+ echo 'pref("javascript.options.baselinejit",      true);'
+ /usr/bin/mkdir -p '/home/komat/rpmbuild/BUILDROOT/firefox-45.0-0.10.el7.x86_64/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}'
+ /usr/bin/mkdir -p '/home/komat/rpmbuild/BUILDROOT/firefox-45.0-0.10.el7.x86_64/usr/lib64/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}'
+ /usr/bin/install -p -c -m 644 LICENSE /home/komat/rpmbuild/BUILDROOT/firefox-45.0-0.10.el7.x86_64//usr/lib64/firefox
+ /usr/bin/rm -rf /home/komat/rpmbuild/BUILDROOT/firefox-45.0-0.10.el7.x86_64/usr/lib64/firefox/dictionaries
+ ln -s /usr/share/myspell /home/komat/rpmbuild/BUILDROOT/firefox-45.0-0.10.el7.x86_64/usr/lib64/firefox/dictionaries
+ rm -rf '/usr/lib/debug/lib/firefox-devel-*'
+ rm -rf '/usr/lib/debug/lib64/firefox-devel-*'
+ /usr/lib/rpm/find-debuginfo.sh --strict-build-id -m --run-dwz --dwz-low-mem-die-limit 10000000 --dwz-max-die-limit 110000000 /home/komat/rpmbuild/BUILD/firefox-45.0

so the '/usr/lib/debug/lib/firefox-devel-*' is deleted from /home/komat/rpmbuild/BUILD/firefox-45.0/firefox-45.0b5 directory. Looks like your ones are deleted from root?

Also I don't know why 'firefox-devel-*' was translated to 'firefox-devel-38.6.0'? Maybe old data in your build root?

Anyway, build works fine on Brew and also on my clearly installed RHEL7.2 box.
Comment 3 Tomas Pelka 2016-02-19 14:04:37 EST
It is definitely possible. Closing as we will waive all srpmtests due to bundeled gcc.

Note You need to log in before you can comment on or make changes to this bug.