Bug 1309658 - Audio devices not found with Linux 4.5.0
Audio devices not found with Linux 4.5.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 06:37 EST by Russel Winder
Modified: 2016-03-04 08:18 EST (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-04 08:18:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russel Winder 2016-02-18 06:37:59 EST
Using Rawhide fully up to date as at 2016-02-18T11:36.

If I boot 4.4.0 kernel everything works fine. If I boot the 4.5.0 kernel then the audio devices are not found by GNOME. They are there in the lspci listing, but nothing appears in the GNOME settings and sound will not play.

…
01:00.1 Audio device: NVIDIA Corporation GF119 HDMI Audio Controller (rev a1)
…
09:02.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 05)
09:02.1 Input device controller: Creative Labs SB Live! Game Port (rev 05)
…
Comment 1 Russel Winder 2016-02-19 22:27:33 EST
This problem appears for me only for my Dell Precision T5400 workstation. My Lenovo ThinkPad laptops seem to be happily picking up the built in speakers.
Comment 2 Jan Kurik 2016-02-24 10:25:53 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Russel Winder 2016-02-25 02:42:14 EST
I note that there is a similar problem booting Debian Sid. There though everything works fine with kernel 4.2 and 4.3, but fails with kernel 4.4.

Maybe this is a kernel problem rather than a GNOME audio one. Should I reports a new bug or should this one be transferred to the people who are best positioned to fix the issue?

cf. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815787
Comment 4 Russel Winder 2016-02-25 14:09:20 EST
The problem seems to be that the emu10k drivers are not being distributed with the 4.5 kernel.

 |> find /usr/lib -iname "*emu10k*"
/usr/lib/modules/4.4.0-1.fc24.x86_64/kernel/drivers/input/gameport/emu10k1-gp.ko.xz
/usr/lib/modules/4.4.0-1.fc24.x86_64/kernel/sound/pci/emu10k1
/usr/lib/modules/4.4.0-1.fc24.x86_64/kernel/sound/pci/emu10k1/snd-emu10k1-synth.ko.xz
/usr/lib/modules/4.4.0-1.fc24.x86_64/kernel/sound/pci/emu10k1/snd-emu10k1x.ko.xz
/usr/lib/modules/4.4.0-1.fc24.x86_64/kernel/sound/pci/emu10k1/snd-emu10k1.ko.xz
/usr/lib/modules/4.5.0-0.rc5.git0.1.fc24.x86_64/kernel/drivers/input/gameport/emu10k1-gp.ko.xz
/usr/lib/modules/4.5.0-0.rc4.git3.1.fc24.x86_64/kernel/drivers/input/gameport/emu10k1-gp.ko.xz
Comment 5 Laura Abbott 2016-02-25 20:42:58 EST
So 4.5 brought in changes for ZONE_DEVICE which is needed for persistent memory devices. The version that was merged required ZONE_DMA be turned off. That particular module depends on ZONE_DMA so it was not being built at all.

There's a patch to fix this. I put it in rawhide. You should see the change in the next rawhide build.
Comment 6 Russel Winder 2016-03-04 03:22:22 EST
The necessary files appear to be back in rc6, certainly sound works again :-)

Thanks for getting the patch in place.

Note You need to log in before you can comment on or make changes to this bug.