Bug 1309659 - [tiering]: Performing a gluster vol reset, turns off 'features.ctr-enabled' on a tiered volume
[tiering]: Performing a gluster vol reset, turns off 'features.ctr-enabled' o...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
tier-glusterd
: ZStream
Depends On: 1290779
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 06:39 EST by hari gowtham
Modified: 2016-06-16 09:57 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1290779
Environment:
Last Closed: 2016-06-16 09:57:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-18 06:40:56 EST
REVIEW: http://review.gluster.org/13470 (TIER: avoid reset of ctr-enabled during the issue of gluster v reset) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2016-02-29 06:44:56 EST
COMMIT: http://review.gluster.org/13470 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 69af0676c9e55804338abe26b94138da15385747
Author: hari <hgowtham@redhat.com>
Date:   Thu Feb 18 16:58:28 2016 +0530

    TIER: avoid reset of ctr-enabled during the issue of gluster v reset
    
    Change-Id: I3f5f29378c8c55cc07a83f5fc1506c4d7e9ac09d
    BUG: 1309659
    Signed-off-by: hari <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/13470
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 3 Mike McCune 2016-03-28 18:40:27 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Niels de Vos 2016-06-16 09:57:48 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.