Bug 1309668 - Issue with modesetting & nouveau
Issue with modesetting & nouveau
Status: CLOSED DUPLICATE of bug 1302847
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2016-02-18 07:13 EST by Erwan Velu
Modified: 2016-02-18 22:31 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-02-18 22:31:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The strace which shows the issue with xrandr (66.85 KB, text/plain)
2016-02-18 07:13 EST, Erwan Velu
no flags Details

  None (edit)
Description Erwan Velu 2016-02-18 07:13:40 EST
Created attachment 1128204 [details]
The strace which shows the issue with xrandr

Description of problem:
I'm running FC23 with Kernel 4.3.5-300.fc23.x86_64 on a Lenovo W541.

It uses nouveau on a NVIDIA GPU Quadro K1100M (GK107GL) at PCI:1:0:0 (GPU-0)
( Memory: 2097152 kBytes, VideoBIOS: 80.07.ac.00.20 PCI Express Link width: 16X)

When I launch some apps (not all), the whole system is freezing for 10s and then is back to normal. This doesn't prevent from using the system but that's pretty annoying.

Dmesg reports :

[81950.342001] nouveau 0000:01:00.0: DRM: resuming kernel object tree...
[81950.989934] nouveau 0000:01:00.0: devinit: 0x64da[0]: script needs connector type
[81955.077779] nouveau 0000:01:00.0: DRM: resuming client object trees...
[81959.082240] nouveau 0000:01:00.0: DRM: resuming display...
[81959.082266] nouveau 0000:01:00.0: DRM: resuming console...
[81964.595864] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150818/nsarguments-95)
[81964.596113] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150818/nsarguments-95)
[81964.596343] nouveau 0000:01:00.0: DRM: suspending console...
[81964.596347] nouveau 0000:01:00.0: DRM: suspending display...
[81964.596359] nouveau 0000:01:00.0: DRM: evicting buffers...
[81964.596360] nouveau 0000:01:00.0: DRM: waiting for kernel channels to go idle...
[81964.596386] nouveau 0000:01:00.0: DRM: suspending client object trees...
[81968.606688] nouveau 0000:01:00.0: DRM: suspending kernel object tree...

I discussed that issue with Jerome Glisse which helped me at localizing where the issue is.

He told me there is maybe an issue with the modesetting when someone is listing the connectors.

I've been adding an strace of xrandr showing that 10sec freeze like in :
12:31:07.921386 poll([{fd=3, events=POLLIN}], 1, -1) = 1 ([{fd=3, revents=POLLIN}]) <9.057474>
12:31:16.978913 recvmsg(3, {msg_name(0)=NULL, msg_iov(1)=[{"\1\0\f\0\353\1\0\0d\245\f\0002\245\f\0\10\0\f\0/\0z\1\0\0\0\0\0\0\0\0", 4096}], msg_controllen=0, msg_flags=0}, 0) = 32 <0.000013>

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Log into gnome
2. try xrandr in console or starts the configuration panel
3. locks occurs

Actual results:
System is locking for ~10sec

Expected results:
No lock ;)

Additional info:
I'm available for any testing.
Comment 1 Erwan Velu 2016-02-18 07:14:39 EST
Adding bskeggs@redhat.com in CC as Jerome Glisse told me he would be helpful.
Comment 2 Dave Airlie 2016-02-18 22:31:54 EST

*** This bug has been marked as a duplicate of bug 1302847 ***

Note You need to log in before you can comment on or make changes to this bug.