Bug 1309675 - perl-DBD-SQLite-1.50-1.fc24 FTBFS: t/43_fts3.t test fails
perl-DBD-SQLite-1.50-1.fc24 FTBFS: t/43_fts3.t test fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-DBD-SQLite (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
: Reopened
Depends On: 1308765
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 07:40 EST by Petr Pisar
Modified: 2016-04-01 01:48 EDT (History)
5 users (show)

See Also:
Fixed In Version: perl-DBD-SQLite-1.50-2.fc24 perl-DBD-SQLite-1.48-4.fc23 perl-DBD-SQLite-1.46-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-01 01:48:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-02-18 07:40:34 EST
perl-DBD-SQLite-1.50-1.fc24 fails to build in F24 because of rebased sqlite that disabled ENABLE_FTS3_TOKENIZER:

t/42_primary_key_info.t ............................... ok
DBD::SQLite::db do failed: unknown tokenizer: perl at t/43_fts3.t line 87.

#   Failed test 'no warnings'
#   at inc/Test/NoWarnings.pm line 38.
# There were 1 warning(s)
#       Previous test 1 'An object of class 'DBI::db' isa 'DBI::db''
#       DBD::SQLite::db do failed: unknown tokenizer: perl at t/43_fts3.t line 87.
#  at t/43_fts3.t line 87.
#
# Looks like you planned 35 tests but ran 2.
# Looks like you failed 1 test of 2 run.
# Looks like your test exited with 255 just after 2.
t/43_fts3.t ...........................................
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 34/35 subtests

Difference between working and failing build root:

        sqlite-devel 	3.10.2-3.fc24 	> 	3.11.0-1.fc24
	glibc 	2.22.90-35.fc24 	> 	2.22.90-36.fc24
	sqlite 	3.10.2-3.fc24 	> 	3.11.0-1.fc24
	sqlite-libs 	3.10.2-3.fc24 	> 	3.11.0-1.fc24
	glibc-common 	2.22.90-35.fc24 	> 	2.22.90-36.fc24
	krb5-libs 	1.14-20.fc24 	> 	1.14-21.fc24
	glibc-devel 	2.22.90-35.fc24 	> 	2.22.90-36.fc24
	systemd-libs 	229-1.fc24 	> 	229-2.fc24
	gdb 	7.10.90.20160211-52.fc24 	> 	7.10.90.20160216-54.fc24
	libicu 	56.1-1.fc24 	> 	56.1-3.fc24
	kernel-headers 	4.5.0-0.rc3.git3.1.... 	> 	4.5.0-0.rc4.git0.1....
	binutils 	2.26-10.fc24 	> 	2.26-11.fc24
	glibc-headers 	2.22.90-35.fc24 	> 	2.22.90-36.fc24
	lzo 	2.08-6.fc24 	> 	2.08-7.fc24
	systemd 	229-1.fc24 	> 	229-2.fc24
	gnupg2 	2.1.10-4.fc24 	> 	2.1.11-1.fc24
	python3-pyparsing 	2.1.0-1.fc24 	> 	2.1.0-2.fc24
Comment 1 Petr Pisar 2016-02-18 08:41:03 EST
Let's wait for getting sqlite-3.11.0 stable to rebuild against it.
Comment 2 Fedora Update System 2016-02-22 02:31:52 EST
perl-DBD-SQLite-1.48-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0e67ba6792
Comment 3 Fedora Update System 2016-02-23 10:20:47 EST
perl-DBD-SQLite-1.48-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0e67ba6792
Comment 4 Jan Kurik 2016-02-24 10:25:59 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Fedora Update System 2016-03-02 16:23:04 EST
perl-DBD-SQLite-1.48-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2016-03-23 03:12:14 EDT
perl-DBD-SQLite-1.46-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4deb64b3c1
Comment 7 Fedora Update System 2016-03-23 21:01:03 EDT
perl-DBD-SQLite-1.46-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4deb64b3c1
Comment 8 Fedora Update System 2016-04-01 01:48:39 EDT
perl-DBD-SQLite-1.46-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.