Bug 1309702 - texi2dvi exits without completing the task
texi2dvi exits without completing the task
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texinfo (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 09:09 EST by Mattias Ellert
Modified: 2016-02-24 06:27 EST (History)
3 users (show)

See Also:
Fixed In Version: texinfo-6.1-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-24 06:27:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This example was extracted from the failing package build (23.27 KB, application/x-xz)
2016-02-18 09:09 EST, Mattias Ellert
no flags Details

  None (edit)
Description Mattias Ellert 2016-02-18 09:09:52 EST
Created attachment 1128230 [details]
This example was extracted from the failing package build

Description of problem:

This problem was discovered as a failure to run texi2dvi as part of a package build for Fedora rawhide in koji. The same build for Fedora 23 works.

Version-Release number of selected component (if applicable):

texinfo-tex-6.1-1.fc24.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Unpack and step into the directory from the attached example tarfile.
2. $ texi2dvi --pdf --no-line-error --max-iterations=20 Rcpp-FAQ.tex > log.txt
3. $ echo $?


Actual results:

On Fedora rawhide this returns "1", i.e. failure.

Grepping for "This is" in the log.txt reveals that pdfTeX was run once and nothing more.

This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2016/dev) (preloaded format=pdflatex)


Expected results:

Running the same example on Fedora 23 returns "0", i.e. success.

Grepping for "This is" in the log.txt reveals that pdfTeX and BibTeX were run multiple times to complete the task

This is pdfTeX, Version 3.14159265-2.6-1.40.15 (TeX Live 2014) (preloaded format=pdflatex)
This is BibTeX, Version 0.99d (TeX Live 2014)
This is pdfTeX, Version 3.14159265-2.6-1.40.15 (TeX Live 2014) (preloaded format=pdflatex)
This is BibTeX, Version 0.99d (TeX Live 2014)
This is pdfTeX, Version 3.14159265-2.6-1.40.15 (TeX Live 2014) (preloaded format=pdflatex)
This is pdfTeX, Version 3.14159265-2.6-1.40.15 (TeX Live 2014) (preloaded format=pdflatex)

Additional info:
Comment 1 Vitezslav Crhonek 2016-02-23 03:54:34 EST
Hello Mattias,

I'm not able to reproduce the issue, missing some dependencies probably... it fails with:
! LaTeX Error: File `Sweave.sty' not found.

Which package did you build and is failing? I can take a look and also get correct dependencies from there.

BTW it seems that this issue has already come to upstream attention:
http://lists.gnu.org/archive/html/bug-texinfo/2016-02/msg00121.html
Comment 2 Mattias Ellert 2016-02-23 04:09:15 EST
Hi!

The package is R-Rcpp the build requires are:

$ grep BuildReq R-Rcpp.spec
BuildRequires:	R-core-devel
BuildRequires:	R-RUnit
BuildRequires:	R-highlight
BuildRequires:	R-inline
BuildRequires:	tex(vmargin.sty)
BuildRequires:	tex(mathdesign.sty)
BuildRequires:	tex(texnansi.enc)

The Sweave.sty is from R-core (a dependency of R-core-devel)
Comment 3 Vitezslav Crhonek 2016-02-23 04:38:37 EST
Thanks, reproduced.
Comment 4 Vitezslav Crhonek 2016-02-23 05:14:59 EST
It doesn't run BibTeX at all.

You can workaround it by running the command twice, for the first time without -p/--pdf option:
$ texi2dvi --no-line-error --max-iterations=20 Rcpp-FAQ.tex > log.txt
$ texi2dvi --pdf --no-line-error --max-iterations=20 Rcpp-FAQ.tex > log.txt

(The first command will return "1" - this seems to be similar to the upstream reported error mentioned in comment #1, the second will return "0" and the .pdf file will contain "Reference" page.)

I'll try to figure out what's wrong.

Note You need to log in before you can comment on or make changes to this bug.