Bug 1309710 - spacecmd needs a kickstart_setsoftwaredetails command
spacecmd needs a kickstart_setsoftwaredetails command
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
2.4
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Ondrej Gajdusek
Pavel Studeník
: FutureFeature
Depends On:
Blocks: 1395882 space27
  Show dependency treegraph
 
Reported: 2016-02-18 09:31 EST by David Haines
Modified: 2017-09-27 15:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: kickstart_setsoftwaredetails or equivalent Reason: no way to toggle noBase or ignoreMissing flags via spacecmd Result:
Story Points: ---
Clone Of:
: 1395882 (view as bug list)
Environment:
Last Closed: 2017-09-27 15:05:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Haines 2016-02-18 09:31:51 EST
spacecmd has kickstart_getsoftwaredetails, which is great for looking at the noBase and ignoreMissing flags. We need a way to set them as well.
Comment 1 Ondrej Gajdusek 2016-08-23 04:53:51 EDT
mofified, implemented in commit: 8c798c269b4be117c2799a6e67919ce2e4c26103
Comment 3 Pavel Studeník 2016-11-14 10:26:51 EST
Reproducer: Spacewalk 2.5 (spacecmd-2.5.8-1.el7.noarch)

>> spacecmd
spacecmd {SSM:0}> kickstart_setsoftwaredetails test-01 noBase True
*** Unknown syntax: kickstart_setsoftwaredetails test-01 noBase True

Verified with spacecmd-2.6.16-1.fc24.noarch:

>> spacecmd
spacecmd {SSM:0}> kickstart_getsoftwaredetails test-01
noBase:        False
ignoreMissing: False
spacecmd {SSM:0}> kickstart_setsoftwaredetails test-01 noBase True 
spacecmd {SSM:0}> kickstart_getsoftwaredetails test-01
noBase:        True
ignoreMissing: False
Comment 4 Eric Herget 2017-09-27 15:05:27 EDT
This looks like it was fixed in previous release, but I'm closing it in this one.

Spacewalk 2.7 has been released.

https://github.com/spacewalkproject/spacewalk/wiki/ReleaseNotes27

Note You need to log in before you can comment on or make changes to this bug.