This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1309713 - [Docs] Review Monitoring, Alerts, and Reporting guide
[Docs] Review Monitoring, Alerts, and Reporting guide
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Documentation (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.7.0
Assigned To: Chris Budzilowicz
Dayle Parker
doc
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 09:34 EST by Shikha
Modified: 2017-08-29 21:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-08 12:21:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Unknown


Attachments (Terms of Use)

  None (edit)
Description Shikha 2016-02-18 09:34:26 EST
Document URL: https://access.redhat.com/documentation/en/red-hat-cloudforms/4.0/monitoring-alerts-and-reporting/monitoring-alerts-and-reporting


Describe the issue: Perform a full review of all the procedures in this guide.

Regards,
Shikha
Comment 2 Dayle Parker 2016-02-21 23:24:22 EST
A few specifics which may need updating (from comments in Gitlab merge request #120)

1) From "Generating Widget Content Immediately"

Generation of widget content is shown under the Tasks page of  (Settings & Operations). 

--> Cannot find this location in CFME.

2) From Changing Report Views - Cannot find the buttons to change the view by following the procedure. For now, 'Graph View', 'Hybrid View', and 'Tabular View', are marked up as guilabels. See if the procedure has changed in 4.0.
Comment 3 Shikha 2016-03-15 22:39:44 EDT
I have completed the review of Monitoring Alerts and Reporting Guide.
Document URL: https://access.redhat.com/documentation/en/red-hat-cloudforms/4.0/monitoring-alerts-and-reporting/monitoring-alerts-and-reporting

The following suggestions should be reviewed.

Chapter 1:
1.5. Open a Chart or Report Widget in Its Own Window has been changed to Full Screen Option. The report open in a new browser window. Other functions can still be accessed through the old browser window while the report is open in another window.

Chapter 3: 3.1.1. Generating a Single Report

Procedure: To Generate a Single Report - Change step 2 to "Click the menu:Reports[All Reports] accordion. Navigate to the report you want to view by selecting the appropriate parent folder."

3.1.2. Scheduling a Report
Procedure: To Schedule a Report
Rewrite step 1 by breaking it into 1 step for each action.
Step 1 substep 3. provide link to the correct section. 

3.1.4. Running a Scheduled Report Immediately

Procedure: To Run a Scheduled Report Immediately Step 3, Change guilabel 'Queue' to 'Queue up this Schedule to run now'

3.2.1. Changing Report Views - Change the 1st paragraph into a Note

3.2.3. Downloading a Report

Procedure: To Download Reports Step 3 change 'sect-Running Reports' to 'Running Reports'. Step 4 change the txt icon in the substeps to match the UI.

3.2.4. Showing a Report in Full Screen Add the procedure for this.

3.3. Adding a Report

Procedure: To Add a Report: change step 2 to "Click the menu:Reports[All Reports] accordion."
Step 6. Markup Note
Step 11, Update the screenshot

3.4. Copying a Report 3.5. Editing a Report 3.6. Deleting a Report 
Step 2 change it to say: Click the menu:Reports[All Reports] accordion.

3.6. Deleting a Report Markup the Note in the introductory para.

3.7 Procedure: To Import a Report 3.8. Exporting a Report
Reword step 2 to say: Select Custom Reports from the Import/Export accordion.

3.8. Exporting a Report Rewrite this sentence for better clarity:
Reports are stored in the VMDB; however, you can share customized reports among VMDBs. To do this use the export and import feature of reports. 

3.9.1. Managing Report Menu Accordions 
Procedure: To Manage Report Menu Accordions-Step 4 All icons need to be updated

3.9.2. Managing Report Menu Folders
Procedure: To Manage Report Menu Folders-Step 5 All icons need to be updated

3.9.3. Organizing Reports in Report Menus
Procedure: To Organize Reports in Report Menus-Step 6 All icons need to be updated

4.1. Accessing Usage Data
Procedure: To Access Usage Data: Cannot find Usage under Cloud Intelligence

5.2. Creating Chargeback Rates
Procedure: To Create Chargeback Rates- Step 3 should be 2b

5.4. Creating a Chargeback Report
Procedure: To Create a Chargeback Report- Step 5 All icons need to be updated

7.7. Creating a hostd Log Threshold Alert
Procedure: To Create a Hostd Log Threshold Alert
Step 4- Change the screenshot
4b- Host is now Host/Node

7.9. Creating an Expression Alert
Procedure: To Create an Expression Alert
Step 3- Change the screenshot
3b- Host is now Host/Node
4. Update the link

7.10. Create an Operational Alert
Procedure: To Create an Operational Alert
3b should be "What to Evaluate"

7.11. Operational Alert Types
Table 7.1. Operational Alerts
Provide content for the 'Proposed Action if Alert is Raised' for the following:
EVM Server Start 
EVM Server Stop
EVM Worker Started 
EVM Worker Stopped 
EVM Worker Killed 
EVM Worker Not Responding 
EVM Worker Exceeded Memory Limit 
EVM Worker Exceeded Uptime Limit 
EVM Worker Exit File 

8.1. Creating Alert Profiles
Procedure: To Create an Alert Profile
Step 2 has a few options and the consequent options change wrt the choice made. Either accommodate all the choices and subsequent actions or add a Note about this. I suggest adding a screenshot of the multiple profiles under the Alert Profile tab and then editing the UI options to <replaceable> unmarked GUI labels, such as, 'Select the desired alerts from the Available Alerts area'

9.1. Importing and Exporting Policies, Policy Profiles, and Alerts
Procedure: To Import a Policy, Policy Profile, or an Alert
step 3 Change Browse to Choose File

Regards,
Shikha
Comment 6 Lucy Bopf 2016-05-25 22:22:32 EDT
Moving to NEW to be reviewed as the schedule allows.
Comment 7 Andrew Dahms 2016-11-01 00:31:30 EDT
Assigning to Chris for review.

Chris - this was an internally created bug suggesting a review of the guide in question. Take a look and see if we can still incorporate the suggestions above into the guide in its current state. If so, great, but if it looks like it may take longer to investigate everything in detail, feel free to skip those items for now and we'll just update what we can.

Note You need to log in before you can comment on or make changes to this bug.