Bug 1309778 - "dnf upgrade" nonexistent or corrupt local rpm crashes in libhawkey
"dnf upgrade" nonexistent or corrupt local rpm crashes in libhawkey
Status: CLOSED DUPLICATE of bug 1257718
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 11:38 EST by Oliver Henshaw
Modified: 2016-02-22 07:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 07:59:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace from "dnf install nothing.rpm" (54.22 KB, text/plain)
2016-02-18 11:38 EST, Oliver Henshaw
no flags Details

  None (edit)
Description Oliver Henshaw 2016-02-18 11:38:57 EST
Created attachment 1128284 [details]
backtrace from "dnf install nothing.rpm"

Description of problem:

dnf crashes in libhawkey when attempting to upgrade with a corrupted local .rpm, but "dnf install" completes/fails in the expected way.

# touch nothing.rpm
or
# curl -O https://kojipkgs.fedoraproject.org//packages/WHOOPSITYPEDWRONGANDHAVEGOTA404ERRORHTMLPAGEOHDEAR/hawkey/0.6.2/4.fc24/x86_64/hawkey-0.6.2-4.fc24.x86_64.rpm

# dnf install nothing,rpm
Last metadata expiration check performed 0:54:36 ago on Thu Feb 18 14:57:19 2016.
Dependencies resolved.
Nothing to do.
Complete!
# dnf update nothing.rpm
Last metadata expiration check performed 0:55:26 ago on Thu Feb 18 14:57:19 2016.
Segmentation fault (core dumped)

I obtained the attached backtrace with gdb,


Version-Release number of selected component (if applicable):
dnf-1.1.6-2.fc22.noarch
hawkey-0.6.2-2.fc22.x86_64


Expected results:

Do nothing, like "dnf install",


Additional info:

Actually the "dnf install" behaviour could improve too, when two packages have dependencies:
$dnf install selinux-policy.rpm selinux-policy-targeted-CORRUPT.rpm
acts like
$dnf install selinux-policy.rpm
and won't succedd unless I --allowerasing, then it asks to remove the installed selinux-policy-targeted
Comment 1 Michal Domonkos 2016-02-22 07:59:17 EST

*** This bug has been marked as a duplicate of bug 1257718 ***

Note You need to log in before you can comment on or make changes to this bug.