Bug 1309784 - python-libcloud: Provide a Python 3 subpackage
Summary: python-libcloud: Provide a Python 3 subpackage
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-libcloud   
(Show other bugs)
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Bruno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: PYTHON3 PY3PATCH-PUSH
TreeView+ depends on / blocked
 
Reported: 2016-02-18 16:48 UTC by Petr Viktorin
Modified: 2018-03-05 09:42 UTC (History)
9 users (show)

Fixed In Version: python3-libcloud-2.2.1-5.fc29
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-05 09:42:04 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to update spec for python3 (4.89 KB, patch)
2016-05-17 23:12 UTC, philip.worrall
no flags Details | Diff
Rebased patch to update spec for python3 (4.00 KB, patch)
2016-09-07 08:31 UTC, Dominika Krejčí
no flags Details | Diff
2. rebased patch to update spec for Python 3 (3.86 KB, patch)
2016-11-16 13:42 UTC, Dominika Krejčí
no flags Details | Diff

Description Petr Viktorin 2016-02-18 16:48:58 UTC
Upstream, this software supports Python 3. Please provide a Python 3
package for Fedora.


According to the Python packaging guidelines [0], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [1].

The current best practice is to provide subpackages for the two Python
versions (called "Common SRPM" in the guidelines). Alternatively, if
nothing depends on your Python2 package, you can just switch to Python 3
entirely.

It's fine to do this in Rawhide only.


If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://fedoraproject.org/wiki/Packaging:Python
[1] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file

Comment 1 Jan Kurik 2016-02-24 15:26:17 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 2 Petr Viktorin 2016-04-26 16:24:55 UTC
Hello Daniel,

Do you need any help adding Python 3 support to the RPM?

If you need more instructions, a [guide] for porting Python-based RPMs is available.

[guide] http://python-rpm-porting.readthedocs.org/en/latest/index.html

Comment 3 philip.worrall 2016-05-17 23:12 UTC
Created attachment 1158546 [details]
Patch to update spec for python3

Comment 4 philip.worrall 2016-05-17 23:13:28 UTC
Hello,

Please find patch to update the spec file for this package to build a python3 version.

Comment 5 Charalampos Stratakis 2016-06-09 15:16:12 UTC
(In reply to philip.worrall from comment #3)
> Created attachment 1158546 [details]
> Patch to update spec for python3

Could you create a scratch build and test the package maybe in mock, so we can verify that the python 3 subpackage works as expected?

Comment 6 Lumír Balhar 2016-07-27 13:54:43 UTC
Hello.

Your patch looks good to me, but it needs to be rebased to current specfile version. Could you also provide scratch build and test it in mock?

Then I can move it forward to push.

Thank you.

Comment 7 Lumír Balhar 2016-08-23 06:22:58 UTC
Hello.

Is there any problem with rebase? Do not hesitate to contact me for any help.

Comment 8 Dominika Krejčí 2016-09-07 08:31 UTC
Created attachment 1198583 [details]
Rebased patch to update spec for python3

Hi, I have rebased the patch and also fixed rpmlint error and warning about demos.

Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=15527540

Comment 9 Lumír Balhar 2016-09-19 13:35:36 UTC
Hello, Dominiko.

Your patch looks good to me, thanks.

If maintainer has nothing against, we can push this change after a week.

Have a nice day.
Lumir

Comment 10 Dominika Krejčí 2016-11-16 13:42 UTC
Created attachment 1221154 [details]
2. rebased patch to update spec for Python 3

Hi, there is a new rebased patch. :)

+ koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=16474811

Comment 11 Charalampos Stratakis 2016-11-16 15:57:09 UTC
Fixed for rawhide, please reopen the bug if you require this change for F25 as well.

Comment 12 Iryna Shcherbina 2017-11-27 10:29:24 UTC
Hi Sayan,

I am reopening the ticket, as since commit [0] building python3-libcloud was disabled for Fedora.

Given that python3-pytest-runner is available, I do not see the reason for this change. Could you please provide any details?

[0] https://src.fedoraproject.org/rpms/python-libcloud/c/776623107cb6b13d4b18dbda4d8b35c0a8c46927?branch=master

Comment 13 Robert-André Mauchin 2018-02-22 13:06:54 UTC
Bump, I need the python 3 package.

Comment 14 Sayan Chowdhury 2018-03-01 18:04:34 UTC
Hi Iryna,
 
Without the python-pytest-runner package mentioned in BuildRequires while building it was trying to pull the dependency from pypi and hence failed. So, I mentioned the package name explicitly in the specfile.

I have updated the specfile to build[0] the python3-libcloud package.

[0] https://koji.fedoraproject.org/koji/buildinfo?buildID=1052225

Comment 15 Iryna Shcherbina 2018-03-05 09:42:04 UTC
Thanks Sayan.


Note You need to log in before you can comment on or make changes to this bug.