Bug 1309912 - Unnecessary vdsm-cli dependency pulled in by host-deploy
Unnecessary vdsm-cli dependency pulled in by host-deploy
Status: CLOSED NOTABUG
Product: ovirt-host-deploy
Classification: oVirt
Component: Plugins.VDSM (Show other bugs)
---
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Sandro Bonazzola
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 18:50 EST by Fabian Deutsch
Modified: 2016-02-24 10:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-24 10:06:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sbonazzo: ovirt‑4.0.0?
rule-engine: planning_ack+
sbonazzo: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53831 master ABANDONED packaging: drop vdsm-cli dependency 2016-02-24 10:05 EST

  None (edit)
Description Fabian Deutsch 2016-02-18 18:50:49 EST
Description of problem:
Currently host-deploy will install a couple of packages on a system which are not required by vdsm itself, (i.e. vdsm-cli).

The question is: Why are those packages not dependencies of vdsm - if they are required by it?

The complete list of packages beeing installed by host-deploy at deploy time is here:
https://gerrit.ovirt.org/gitweb?p=ovirt-host-deploy.git;a=blob;f=ovirt-host-deploy-offline.spec.in;hb=HEAD#l31

Version-Release number of selected component (if applicable):
3.6

How reproducible:
Always

Steps to Reproduce:
1. Install vdsm on a host
2. Disable all repos
3. Try adding the host to Engine

Actual results:
After 3: Failure because vdsm-cli can not be installed.

Expected results:
By manually installing vdsm in step 2, all required dependencies willl be installed.

Additional info:
Comment 1 Sandro Bonazzola 2016-02-22 08:32:15 EST
vdsm-cli is there since initial commit: Sun Nov 18 02:20:25 2012.
It seems it's not used in any critical path so I'm fine with dropping it.
Comment 2 Sandro Bonazzola 2016-02-24 10:06:13 EST
vdsm-cli is a required dependency of the sos plugin shipped within vdsm.
Please open a bz on vdsm for adding proper dependency there.

Note You need to log in before you can comment on or make changes to this bug.