This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1309928 - [doc] New guide: "DevOps:using Ansible to create a ceph Deployment"
[doc] New guide: "DevOps:using Ansible to create a ceph Deployment"
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
1.3.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.0
Assigned To: John Wilkins
Rachana Patel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-18 20:04 EST by Federico Lucifredi
Modified: 2016-08-23 15:31 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:31:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Federico Lucifredi 2016-02-18 20:04:18 EST
Description of problem:


We want to introduce a new document to describe how a customer can integrate their own deployment process for Ceph using Red Hat supported Ansible modules.

As this is an open-ended exercise, the guide just needs to walk the customer through the operation of the ansible modules.


I recommend Documentation ask Dev or QE for assistance as the outline for this document ( effectively, a documented example of how to create a Ceph cluster using Ansible ) is something that developers do every day. Even a shell log of their work would provide a good starting point.


This is separate from the other two setup references to be included in 2.0 
(1) creating a cluster with pure CLI — this is documentation existing upstream, we agreed with J Wilkins to port this downstream as well. This is a new document.

(2) An update of the existing install guides to use USM instead of Ceph deploy. This is an update to the existing primary guides for RHEL and Ubuntu.


(1) and (2) are separate items from this one, and tracked by other bugs.
Comment 5 Rachana Patel 2016-05-12 12:41:29 EDT
1. Doc (mentioned in comment#4 ) doesnt have any info about Calamari installation for ceph installation using ansible - '3.2. INSTALLING RED HAT CEPH STORAGE USING ANSIBLE '

2. Doc doesnt talk about rbd-mirroring.

Hence Moving back to assigned state
Comment 9 Gregory Meno 2016-07-15 17:12:35 EDT
John,
Harish is correct in https://bugzilla.redhat.com/show_bug.cgi?id=1309928#c7

Calamari API is absolutely supported in ceph-2.0. Storage Console depends on it to work.
Comment 10 Harish NV Rao 2016-07-18 02:04:30 EDT
Moving this to assigned state based on comments 9, 7 and 5(1).
Comment 12 Rachana Patel 2016-08-07 11:54:24 EDT
Deployment of ceph cluster using ansible looks good to me.
(there are few bugs in bug but those are being tracked by other Doc bugs, hence moving this to verified state)
Comment 14 errata-xmlrpc 2016-08-23 15:31:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755

Note You need to log in before you can comment on or make changes to this bug.