Bug 130996 - crond crashes intermittently - need debug help
crond crashes intermittently - need debug help
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Jason Vas Dias
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-26 11:14 EDT by Terry
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: vixie-cron-4.1-+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-01 20:15:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry 2004-08-26 11:14:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
Crond seems to crash intermittently.  I need some help obtaining debug
information to post.  Simply starting it with the service command puts
me back in business.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.  Start crond
2.  Wait for crash ( can't give amount of time
3.  Restart it
    

Additional info:
Comment 1 Jason Vas Dias 2004-08-26 11:47:46 EDT
 You should really upgrade to FC2 - FC1 has been "retired" .
 You are running vixie-cron-3.0.1-76 ?
 vixie-cron-4.1-FC2_3 is the latest recommended version for Fedora.
 If you can't upgrade,  or you upgrade and the crash still occurs,
 please do the following : 
 $ grep crond /var/log messages | tail -10 > /tmp/cron_crash.log
 $ tail -10 /var/log/cron >> /tmp/cron_crash.log
 and attach the resulting cron_crash.log file to this bug - that
 should give us a way to start determining the problem.
Comment 2 Terry 2004-08-26 12:23:59 EDT
I have already checked messages for goofy errors and am not getting
any.  Can I enable a debug level in crond somehow?  I can't apply that
latest RPM because FC1 doesnt have SELINUX support.
Comment 3 Jason Vas Dias 2004-08-26 13:05:55 EDT
Is there any reason not to upgrade to FC2 ? 
You can see exactly what's happening as follows - as root:
$ service crond stop
$ ulimit -c unlimited
$ cd /var/spool
$ crond -nx 'ext,sch,proc,pars,load,misc,test,bit' 2>&1 | tee
/tmp/cron_dbg.log
(all on one line).
This will run crond in the foreground, so you won't get another
prompt until it exits.
Then wait for the crash - how long does it take? - and then do:
$ gzip -9 /tmp/cron_dbg.log 
and append the resulting /tmp/cron_dbg.log.gz file to this bug .
If there is a 'core.*' file in the /var/spool directory, please
also compress! the latest! core.* file and append the core.gz to
this bug.  
Comment 4 Terry 2004-08-26 13:58:42 EDT
This is a UML box so upgrading is pretty much starting over.  It
hasn't crashed yet since I last started it so That probably won't
work.  I need to find out how often this is happening.
Comment 5 Jason Vas Dias 2004-08-26 16:06:11 EDT
OK, well if you don't mind a huge /var/log/messages file, do this:
1. Enable core dumps: edit /etc/profile to say:
# No core files by default
# ulimit -S -c 0 > /dev/null 2>&1
ulimit -c unlimited >/dev/null 2>&1
2. Edit /etc/init.d/crond - where it says "daemon crond" in start(),
   make it say:
   daemon crond -x 'ext,sch,proc,pars,load,misc,test,bit'&

All the debug info will now appear in /var/log/messages,
and if crond cores, the corefile will be in /var/spool.

To find out how often it happens, create a cron job:
'* * * * *  /bin/date>>/tmp/cron.alive.txt'
The last date & time string written to /tmp/cron.alive.txt
will be the last time cron ran its jobs.

This really doesn't happen with current version ! 
I'll work on getting a update to vixie-cron-4.1 out to
Fedora 1 & 2 updates.
Comment 6 Jason Vas Dias 2005-06-01 20:15:02 EDT
Just clearing out old bugs here. This one is definitely no longer a
problem.

Note You need to log in before you can comment on or make changes to this bug.