Bug 1309965 - Build failed with eap64-openshift image
Build failed with eap64-openshift image
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image (Show other bugs)
3.2.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: kconner
Wang Haoran
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-19 01:07 EST by Wang Haoran
Modified: 2016-02-23 02:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 02:39:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wang Haoran 2016-02-19 01:07:17 EST
Description of problem:

The eap-64 builder image cannot build successfully

Version-Release number of selected component (if applicable
openshift v3.1.1.903
kubernetes v1.2.0-origin
etcd 2.2.2+git
image id: da33a63bf7dc
How reproducible:
always

Steps to Reproduce:
1.Create a new project
2.Open webconsole select eap64-basic-s2i template and create a app
3.Check the build log

Actual results:
faild with error:
I0219 00:42:14.280813       1 sti.go:551] [INFO] Error stacktraces are turned on.
I0219 00:42:14.722884       1 sti.go:551] [ERROR] Could not create local repository at /home/jboss/.m2/repository -> [Help 1]
I0219 00:42:14.726838       1 sti.go:551] org.apache.maven.repository.LocalRepositoryNotAccessibleException: Could not create local repository at /home/jboss/.m2/repository
I0219 00:42:14.726859       1 sti.go:551] 	at org.apache.maven.DefaultMaven.validateLocalRepository(DefaultMaven.java:504)
I0219 00:42:14.726868       1 sti.go:551] 	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:196)
I0219 00:42:14.728315       1 sti.go:551] 	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
I0219 00:42:14.728430       1 sti.go:551] 	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
I0219 00:42:14.728441       1 sti.go:551] 	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
I0219 00:42:14.728447       1 sti.go:551] 	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
I0219 00:42:14.728606       1 sti.go:551] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
I0219 00:42:14.728612       1 sti.go:551] 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
I0219 00:42:14.728618       1 sti.go:551] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
I0219 00:42:14.728623       1 sti.go:551] 	at java.lang.reflect.Method.invoke(Method.java:497)
I0219 00:42:14.728629       1 sti.go:551] 	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
I0219 00:42:14.728634       1 sti.go:551] 	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
I0219 00:42:14.728648       1 sti.go:551] 	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:414)
I0219 00:42:14.728665       1 sti.go:551] 	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:357)
I0219 00:42:14.728672       1 sti.go:551] [ERROR] 


Expected results:
Build successfully

Additional info:
Comment 3 Tomas Schlosser 2016-02-23 02:39:29 EST
Closing as NOTABUG, because it was reported against unsupported internal build.

Note You need to log in before you can comment on or make changes to this bug.