Bug 1309966 - perl-Test-Mojibake-1.1-2.fc24 FTBFS: t/release-synopsis.t test fails: Global symbol "$file" requires explicit package name (did you forget to declare "my $file"?) at lib/Test/Mojibake.pm line 321.
perl-Test-Mojibake-1.1-2.fc24 FTBFS: t/release-synopsis.t test fails: Global ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Test-Mojibake (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-19 01:09 EST by Petr Pisar
Modified: 2016-02-19 08:30 EST (History)
2 users (show)

See Also:
Fixed In Version: perl-Test-Mojibake-1.1-3.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-19 08:30:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-02-19 01:09:49 EST
perl-Test-Mojibake-1.1-2.fc24 fails to build in F24 because a test fails:

t/release-portability.t ...... ok
#   Failed test 'lib/Test/Mojibake.pm'
#   at /usr/share/perl5/vendor_perl/Test/Synopsis.pm line 24.
# Global symbol "$file" requires explicit package name (did you forget to declare "my $file"?) at lib/Test/Mojibake.pm line 321.
# Global symbol "$num_tests" requires explicit package name (did you forget to declare "my $num_tests"?) at lib/Test/Mojibake.pm line 322.
# Looks like you failed 1 test of 1.
t/release-synopsis.t ......... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests

This is caused by upgrading perl-Test-Synopsis from 0.13-2.fc24 to 0.14-1.fc24.
Comment 1 Paul Howarth 2016-02-19 08:30:14 EST
Build done:
http://koji.fedoraproject.org/koji/taskinfo?taskID=13048308

Tweaked the SYNOPSIS to make it compilable code.

Note You need to log in before you can comment on or make changes to this bug.