Bug 1309980 - Skylake intel_pstate won't boot
Summary: Skylake intel_pstate won't boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 23
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-19 06:52 UTC by Robert Smol
Modified: 2016-05-06 19:52 UTC (History)
10 users (show)

Fixed In Version: kernel-4.5.2-301.fc24 kernel-4.4.8-300.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-23 23:44:56 UTC
Type: Bug


Attachments (Terms of Use)

Description Robert Smol 2016-02-19 06:52:32 UTC
Description of problem:

Fedora 23 won't boot on new Skylake processors. I've tested with install DVD and also with upgraded kernel. The machine hang's during boot on intel_pstate driver. The only way to get around is to turn off with intel_pstate=no_hwp,but this turns off power saving.

Version-Release number of selected component (if applicable):

[rsmol@yoga-laptop ~]$ cat /proc/cpuinfo 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 78
model name	: Intel(R) Core(TM) i5-6200U CPU @ 2.30GHz
stepping	: 3
microcode	: 0x74
cpu MHz		: 746.718
cache size	: 3072 KB


kernel-4.3.5-300.fc23.x86_64

It is Lenovo Yoga 260 HW.

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Blank screen.

Expected results:
Normal boot.

Additional info:

Comment 1 Josh Boyer 2016-02-19 12:25:34 UTC
Skylake support is incomplete in the 4.3.y kernel.  You might have better luck with the 4.4.y kernel, which F23 is being rebased to this week.

Comment 2 Robert Smol 2016-02-21 16:21:33 UTC
Hi, I've tested against kernel-4.5.0-0.rc4.git2.2.fc24.x86_64 it is the same issue, can I somehow test something or help?

sudo dnf config-manager --add-repo=http://alt.fedoraproject.org/pub/alt/rawhide-kernel-nodebug/fedora-rawhide-kernel-nodebug.repo

the last message on screen is: intel pstate hwp

Comment 3 Robert Smol 2016-03-15 12:55:16 UTC
Hi,currently on 4.5.0-1.fc25.x86_64, the issue is still here. Does it mean Skylake will not be supported in F24? The last message I see intel_pstate: HWP enabled and then nothing I have to press power button for 4 seconds.

Comment 4 Robert Smol 2016-04-13 19:52:21 UTC
Hello, today on 4.4.6-301.fc23.x86_64, still same issue. Is there any test I can provide to help this to get fixed? I've also tested F24 alpha, it had same issue ;(

Comment 5 Robert Smol 2016-04-13 20:22:03 UTC
it seems I might be running into this bug. https://bugzilla.kernel.org/show_bug.cgi?id=110941

Comment 6 Robert Smol 2016-04-14 05:56:40 UTC
patch from that bug works! I've followed this guide.

https://www.reddit.com/r/thinkpad/comments/4c6q6w/fixing_intel_pstateno_hwp_issue_on_fedora_23_guide/

 Please consider to include that patch in the kernel and close this bug. Thank you

Comment 7 Laura Abbott 2016-04-14 14:05:36 UTC
Pushed to repositories. It should show up in a build next week.

Comment 8 Fedora Update System 2016-04-20 23:11:32 UTC
kernel-4.5.2-300.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7f37d42add

Comment 9 Fedora Update System 2016-04-20 23:23:58 UTC
kernel-4.4.8-300.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8a1f49149e

Comment 10 Fedora Update System 2016-04-20 23:26:54 UTC
kernel-4.4.8-200.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-373c063e79

Comment 11 Fedora Update System 2016-04-21 21:57:59 UTC
binutils-2.26-18.fc24, kernel-4.5.2-300.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7f37d42add

Comment 12 Fedora Update System 2016-04-22 03:23:26 UTC
kernel-4.4.8-200.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-373c063e79

Comment 13 Fedora Update System 2016-04-22 20:57:41 UTC
kernel-4.4.8-300.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8a1f49149e

Comment 14 Robert Smol 2016-04-23 13:32:58 UTC
I can confirm things works as expected now. Thank you

Comment 15 Fedora Update System 2016-04-23 19:45:19 UTC
binutils-2.26-18.fc24 kernel-4.5.2-301.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7f37d42add

Comment 16 Fedora Update System 2016-04-23 23:44:09 UTC
binutils-2.26-18.fc24, kernel-4.5.2-301.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2016-04-27 21:50:17 UTC
kernel-4.4.8-300.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-05-06 19:52:20 UTC
kernel-4.4.8-200.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.