Bug 1310038 - e-mails from bugzilla sometimes have the wrong date
e-mails from bugzilla sometimes have the wrong date
Status: CLOSED DUPLICATE of bug 1285621
Product: Bugzilla
Classification: Community
Component: Email Notifications (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-19 05:03 EST by Mattias Ellert
Modified: 2016-02-21 17:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-21 17:15:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2016-02-19 05:03:27 EST
Description of problem:

I sometimes get e-mails from bugzilla with the wrong timestamps.

E.g. the email sent for this comment:

https://bugzilla.redhat.com/show_bug.cgi?id=1305887#c2

which on the bugzilla page is timestamped "2016-02-17 17:30:45 EST", has a e-mail header saying:

Date: Tue, 9 Feb 2016 14:00:30 +0000 (2016-02-09 15:00:30)

The bad date header corresponds to the original creation time of the bugzilla ticket.

The Received headers are reasonable;

Received: from bugweb-03.app.bz.hst.phx2.redhat.com (bugweb-03.app.bz.hst.phx2.redhat.com [10.5.117.33])  by mx1-phx2.redhat.com (8.14.4/8.14.4) with ESMTP id u1HFN0Sp042290     (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-GCM-SHA384 bits=256 verify=NO)       for <mattias.ellert@fysast.uu.se>; Wed, 17 Feb 2016 10:23:01 -0500
Received: from bugweb-03.app.bz.hst.phx2.redhat.com (localhost [127.0.0.1])       by bugweb-03.app.bz.hst.phx2.redhat.com (8.14.4/8.14.4) with ESMTP id u1HFN0JY031493    for <mattias.ellert@fysast.uu.se>; Wed, 17 Feb 2016 10:23:00 -0500
Received: (from apache@localhost) by bugweb-03.app.bz.hst.phx2.redhat.com (8.14.4/8.14.4/Submit) id u1HFN0tc031480;       Wed, 17 Feb 2016 10:23:00 -0500


Version-Release number of selected component (if applicable):

4.4

How reproducible:

Occasional - it has not been a one-off since it has happened a few times. But most of the e-mails sent by Bugzilla have good Date headers.

Steps to Reproduce:
1. Not sure how to trigger it.

Actual results:

E-mails sent with wrong time stamp.

Expected results:

E-mails sent with correct time stamp.
Comment 1 Jeff Fearn 2016-02-21 17:15:34 EST

*** This bug has been marked as a duplicate of bug 1285621 ***

Note You need to log in before you can comment on or make changes to this bug.