Bug 1310048 - Container installation with NFS support failed at task Create PersistentVolumes
Container installation with NFS support failed at task Create PersistentVolumes
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Andrew Butcher
Anping Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-19 05:33 EST by Anping Li
Modified: 2016-05-12 12:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 12:38:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1065 normal SHIPPED_LIVE Red Hat OpenShift Enterprise atomic-openshift-utils bug fix update 2016-05-12 16:32:56 EDT

  None (edit)
Description Anping Li 2016-02-19 05:33:27 EST
Description of problem:
Container installation with NFS support failed at task "Create PersistentVolumes"

Version-Release number of selected component (if applicable):
openshift-ansible/master

How reproducible:
always

Steps to Reproduce:
1) enable NFS support in inventory file and enable containerized for each node.
2) ansible-playbook -i config/OSE31nfs /root/openshift-ansible/playbooks/byo/config.yml

Actual results:
TASK: [openshift_persistent_volumes | Deploy PersistentVolume definitions] **** 
ok: [10.3.11.12]

TASK: [openshift_persistent_volumes | Create PersistentVolumes] *************** 
failed: [10.3.11.12] => {"changed": true, "cmd": ["/usr/local/bin/oc", "create", "-f", "/tmp/openshift-ansible-nC4FM3U/persistent-volumes.yml", "--config=/tmp/openshift-ansible-nC4FM3U/admin.kubeconfig"], "delta": "0:00:04.975893", "end": "2016-02-19 08:05:33.320436", "failed": true, "failed_when_result": true, "rc": 0, "start": "2016-02-19 08:05:28.344543", "stdout_lines": ["persistentvolume \"registry1-volume\" created"], "warnings": []}
stderr: 
================================================================================
ATTENTION: You are running oc via a wrapper around 'docker run openshift3/ose'.
This wrapper is intended only to be used to bootstrap an environment. Please
install client tools on another host once you have granted cluster-admin
privileges to a user. 
See https://docs.openshift.com/enterprise/latest/cli_reference/get_started_cli.html
=================================================================================
stdout: persistentvolume "registry1-volume" created

FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/root/config.retry

10.3.11.12                 : ok=225  changed=13   unreachable=0    failed=1   
10.3.14.149                : ok=41   changed=4    unreachable=0    failed=0   
10.3.14.157                : ok=41   changed=3    unreachable=0    failed=0   
172.17.91.17               : ok=33   changed=3    unreachable=0    failed=0   
localhost                  : ok=18   changed=0    unreachable=0    failed=0   


Expected results:


Additional info:
Comment 2 Andrew Butcher 2016-02-23 13:12:12 EST
Proposed fix: https://github.com/openshift/openshift-ansible/pull/1442
Comment 3 Anping Li 2016-02-24 00:17:51 EST
The error disappear with the new version. so move bug to verified.
Comment 5 errata-xmlrpc 2016-05-12 12:38:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1065

Note You need to log in before you can comment on or make changes to this bug.