Bug 1310061 - Problem with running SPECjvm2008 benchmark
Problem with running SPECjvm2008 benchmark
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: java-1.7.0-openjdk (Show other bugs)
7.2
aarch64 Linux
high Severity high
: rc
: ---
Assigned To: Andrew Dinn
Lukas Zachar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-19 06:03 EST by Kamil Kolakowski
Modified: 2016-11-03 18:59 EDT (History)
8 users (show)

See Also:
Fixed In Version: java-1.7.0-openjdk-1.7.0.95-2.6.4.3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 18:59:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm file with benchmark (6.63 KB, application/x-rpm)
2016-02-19 06:46 EST, Jiri Hladky
no flags Details

  None (edit)
Description Kamil Kolakowski 2016-02-19 06:03:24 EST
Description of problem:
We do runs of SPECjvm2008 benchmark to get performance results of linux kernel. But when we running this benchmark on https://beaker.engineering.redhat.com/view/amd-seattle-05.lab.eng.rdu.redhat.com
test always crashed with message ERROR: compiler exit code: 4.
This machine is aarch64 machine and I tried it on another one aarch64 machine apm-mustang-ev3-13.lab.eng.rdu.redhat.com but I get the same result.

I tried 2 version of openjdk 1.7.0 and 1.8.0 on both it crashes.

How to reproduce:
1. Download benchmark from https://www.spec.org/jvm2008/
2. See if you get value operations per minute for every operation in test (compiler, startup etc)

Thanks

Kamil
Comment 2 Jiri Hladky 2016-02-19 06:45:44 EST
Alternately you can install the benchmark from Beaker repo:

yum -y install performance-performance-SPECjvm2008-test-certification.noarch

I will attach the rpm file to this BZ as well.

After the installation do the following:

cd /mnt/tests/performance/SPECjvm2008-test/certification/

Run benchmark with on ARM server
./runtest.sh

After roughly 15 minutes go to 

cd SPECjvm2008/results

and run 
find ./ -name "*error*"

If you see file like this one
compiler.compiler.bt2.i1.op1.error.log

with 

ERROR: compiler exit code: 4

then you have reproduced the issue. We believe it's a bug in java. 

Please feel free to ping either kkolakow or jhladky if you need to get access to ARM server or you require help to reproduce the problem. 

Thanks
Jirka
Comment 3 Jiri Hladky 2016-02-19 06:46 EST
Created attachment 1128519 [details]
rpm file with benchmark
Comment 12 errata-xmlrpc 2016-11-03 18:59:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2140.html

Note You need to log in before you can comment on or make changes to this bug.