Bug 1310091 - quota: disabling and enabling quota in a quick interval removes quota's limit usage settings on multiple directories
quota: disabling and enabling quota in a quick interval removes quota's limit...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-Administration_Guide (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.3
Assigned To: Laura Bailey
Anil Shah
: Documentation, ZStream
Depends On: 1304585
Blocks: 1310215
  Show dependency treegraph
 
Reported: 2016-02-19 07:29 EST by Manikandan
Modified: 2016-09-20 00:29 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-12 21:55:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2016-02-19 07:29:56 EST
Document URL: https://access.redhat.com/documentation/en-US/Red_Hat_Storage/3.1/pdf/Administration_Guide/Red_Hat_Storage-3.1-Administration_Guide-en-US.pdf

Section Number and Name: 14.8 Disabling quotas

Describe the issue: When quota is disabled on a volume, a cleanup process is initiated to clean up the extended attributes used by quota. If this cleanup process is still in progress when quota is re-enabled, extended attributes for the newly enabled quota can be removed by the cleanup process. This has negative effects on quota accounting.

Suggestions for improvement: 

Additional information: 
We would like to add this as a warning in the quota admin guide ( as well as the known issues section ). This is to ensure that the admin knows what to expect if s/he were to disable the quota instead of hitting the issue and then finding it listed as a known issue.
Comment 6 Anil Shah 2016-06-13 06:43:28 EDT
As discussed with Developer(Manikandan), "Note" in section 15.8 is not needed now since this issue is solved with quota version implementation. 

Please remove "Note" from section 15.8 in admin guide.
Comment 8 Anil Shah 2016-06-15 06:25:48 EDT
Doc texts looks good to me.
Comment 9 Laura Bailey 2016-09-12 21:55:02 EDT
Closing bugs released as part of 3.1.3 GA and 3.1.3 Async update.

Note You need to log in before you can comment on or make changes to this bug.