Bug 131015 - cpuspeed shouldn't require changes to config file to find the right driver
cpuspeed shouldn't require changes to config file to find the right driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cpuspeed (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-26 13:35 EDT by Bastien Nocera
Modified: 2015-01-04 17:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-15 21:53:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2004-08-26 13:35:16 EDT
One shouldn't need to modify /etc/cpuspeed.conf to change the driver
to be able to use the cpuspeed daemon. It should be possible to detect
automatically which driver should be used.

For example, kudzu would detect the CPU in the machine, and write out
the correct alias to /etc/modprobe.conf:
alias cpufreq-driver acpi

The cpuspeed init script would then try to load that driver before
running.

(This is an RFE slightly larger than just this module, but upstream
doesn't seem to have a mailing-list or a forum to discuss this problem)
Comment 1 Bill Nottingham 2004-08-27 12:14:08 EDT
Also, we appear to have some modules built in, and some modules built
as modules. :/
Comment 2 Dave Jones 2006-07-15 21:53:06 EDT
the modular/non-modular thing is intentional.   Building them all in solves the
problem of figuring out which module to load from userspace.

Basically, by the time we get to userspace, we should have a valid driver setup,
and if we haven't then the cpuspeed init script will load acpi-cpufreq as a
fallback.

The other drivers that /are/ modular are done so because probing for them is
unsafe and has been known to cause problems on some boxes.

in the majority of cases, you should never have to set the DRIVER line in the
cpuspeed config.

Note You need to log in before you can comment on or make changes to this bug.