Bug 1310155 - libvirt-devel should not require libvirt-doc
libvirt-devel should not require libvirt-doc
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-19 10:41 EST by Clément DAVID
Modified: 2016-04-20 09:16 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-20 09:16:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clément DAVID 2016-02-19 10:41:39 EST
Description of problem:

The devel package should not require the documentation. Quoting the guidelines :

> For example API documentation belongs in the -devel subpackage, not the main one. Or if there's a lot of documentation, consider putting it into a subpackage. In this case, it is recommended to use *-doc as the subpackage name. 

So either put everything into the -devel package or provide a -doc package for API documentation without pulling it automatically on -devel install.
Comment 1 Cole Robinson 2016-04-13 10:59:23 EDT
Thanks for the report. I sent a patch upstream:

http://www.redhat.com/archives/libvir-list/2016-April/msg00720.html
Comment 2 Cole Robinson 2016-04-20 09:16:22 EDT
Upstream now:

commit feffcc03a0d3690dcffd860682dcbaa61d726b39
Author: Cole Robinson <crobinso@redhat.com>
Date:   Wed Apr 13 10:37:42 2016 -0400

    spec: Only pull in API docs with -devel package


I've pulled this into the libvirt upstream v1.2.18-maint branch, next time we rebase in f23 it will be fixed. Just closing otherwise since it's not a big deal

Note You need to log in before you can comment on or make changes to this bug.