Bug 1310280 - rhds10 doc perf tuning guide - incorrect file descriptors example
rhds10 doc perf tuning guide - incorrect file descriptors example
Status: CLOSED DUPLICATE of bug 1314129
Product: Red Hat Directory Server
Classification: Red Hat
Component: Doc-performance-and-tuning (Show other bugs)
10.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marc Muehlfeld
Viktor Ashirov
:
: 1292365 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-19 19:17 EST by Marc Sauton
Modified: 2016-11-28 08:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-28 08:58:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Sauton 2016-02-19 19:17:09 EST
Description of problem:

The RHDS 10 doc is showing the RHEL 6 configuration, it needs to be updated for RHEL 7


https://access.redhat.com/documentation/en-US/Red_Hat_Directory_Server/10/html/Performance_Tuning_Guide/file-descriptors.html#ds-file-descriptors
 ⁠
3.3.2. Setting Directory Server File Descriptor Values

"
 To reset the file descriptors for Directory Server:

    Edit the /etc/sysconfig/dirsrv file and add a new line setting the process ulimit.

    ulimit -n 8192
"

should be

"
 To tune the number of file descriptors for the Red Hat Directory Server:

    Edit the file /etc/sysconfig/dirsrv.systemd and uncomment the line specifying the file descriptor limit:

    LimitNOFILE=8192

or use the string "infinity" to configure with "no limit", but limited by /proc/sys/fs/file-max
or sysctl fs.file-max 
"


and

3.3.1. Resetting the Host Machine's File Descriptors
also shows the RHEL6 statements

"
2. If the setting is lower than 64000, edit the /etc/sysctl . co nf file, and reset the fs.file-
max parameter:
fs.file-max = 64000
3. Then increase the maximum number of open files on the system by editing the
/etc/security/limits.conf configuration file. Add the following entry:
*
-
nofile
8192
4. Edit the /etc/pam.d/system-auth, and add this entry:
session required pam_limits.so
5. Reboot the machine to apply the changes.
"

I am not sure why it need to change PAM related settings for the LDAP service, the /etc/security/limits.conf may not be necessary, and /etc/pam.d/system-auth already has by default the line
session     required      pam_limits.so


so I would propose this:

"
2. If the setting is lower than 64000, modify its value

either for a temporary change:
sysctl -w fs.file-max=64000

or for a permanent change, edit the configuration file /usr/lib/sysctl.d/00-system.conf
fs.file-max = 64000

3. Reboot the system to apply the changes.
"

I tested with a super low FD number, reboot, and could not start ns-slapd as expected, so this simple configuration seem to properly affect the file descriptor configuration for RHDS 10 on RHEL 7


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Marc Muehlfeld 2016-11-25 05:33:09 EST
*** Bug 1292365 has been marked as a duplicate of this bug. ***
Comment 2 Marc Muehlfeld 2016-11-28 08:58:23 EST
We have the same outdated content in the DS Installation Guide. To avoid duplicate content, I replaced the section in the Performance Tuning Guide with a link to the section in the Installation Guide.

I think the Install Guide is the better location for the content, because the DS setup script checks the file descriptors during the installation and recommends updating the settings, if necessary.

For fixing the section in the Install Guide, BZ#1314129 exists. I'm closing this one as duplicate.

*** This bug has been marked as a duplicate of bug 1314129 ***

Note You need to log in before you can comment on or make changes to this bug.