Bug 1310287 - rpm update should not restart server
rpm update should not restart server
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mariadb (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Dorňák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-19 19:55 EST by Dennis Jacobfeuerborn
Modified: 2016-02-24 10:27 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-24 08:27:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Jacobfeuerborn 2016-02-19 19:55:08 EST
Apparently the current server rpm restarts the server when the rpm gets updated. Given that this could be a really heavy weight operation this is a really bad idea since this process can take a very long time and if something happens during that time you end up with a half finished yum transaction.
Also a call to mysql_upgrade call might be necessary between a stop and restart of the database. 
Given that only then admin has the knowledge when and how to restart the database properly and the package can only make one-size-fits-all decisions this automatic restart should be removed from the package.
Comment 1 Terje Røsten 2016-02-22 16:47:21 EST
It's common pattern for server packages in fedora to *restart* themselves during
rpm/yum/dnf upgrades, however scripts will not *start* a stopped service. 

If you don't want the automatic restart, stop the server service before doing packages upgrade and start after package tools have done their jobs.
Comment 2 Honza Horak 2016-02-24 08:27:31 EST
(In reply to Dennis Jacobfeuerborn from comment #0)
> Apparently the current server rpm restarts the server when the rpm gets
> updated. Given that this could be a really heavy weight operation this is a
> really bad idea since this process can take a very long time and if
> something happens during that time you end up with a half finished yum
> transaction.

I agree with Terje here, this is the behavior users are used to in Fedora and it makes sense to keep all services behave the same. Also I don't here any other admins who would have problem with it.

> Also a call to mysql_upgrade call might be necessary between a stop and
> restart of the database. 

This is usually required only when updating to new major version, which we don't change during one release, so mysql_upgrade is usually run after system upgrade (e.g. from F23 to F24).

> Given that only then admin has the knowledge when and how to restart the
> database properly and the package can only make one-size-fits-all decisions
> this automatic restart should be removed from the package.

At the same time, admin is also responsible for updating and when mariadb-server should not be updated, he must say this to DNF and run the RPM update of mariadb once database is prepared for it.
Comment 3 Jan Kurik 2016-02-24 10:27:26 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Note You need to log in before you can comment on or make changes to this bug.