Bug 131031 - Wrongly detected burn possibilities with k3b
Wrongly detected burn possibilities with k3b
Status: CLOSED DUPLICATE of bug 130576
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-26 15:03 EDT by František Dvořák
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description František Dvořák 2004-08-26 15:03:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
After upgrading kernel from 2.6.6-1.435 to 2.6.8-1.521 is imposible
burn CD-R and DVD+RW. k3b misdetect it. Running k3b under root is w/o
problems. 
2.6.6 was OK.
SELinux was always disabled.

Version-Release number of selected component (if applicable):
2.6.8-1.521

How reproducible:
Always

Steps to Reproduce:
1. login as non-root user (with access to /dev/cdrom for burning)
2. run k3b
3. open the configuration or try burn CD-R or DVD+RW
    

Actual Results:  It's impossible under normal user.

Expected Results:  With right permission on /dev/hdd enable user burning.



Additional info:

Permissions:

[root@finet valtri]# ls -la /dev/hdd
brw-------  1 valtri disk 22, 64 �no 23  2004 /dev/hdd

[valtri@finet valtri]$ id
uid=500(valtri) gid=500(valtri) skupiny=500(valtri),501(read),503(burning)

Strace with 2.6.6 kernel:
open("/proc/sys/dev/cdrom/info", O_RDONLY|O_LARGEFILE) = 10
open("/dev/hdd", O_RDONLY|O_NONBLOCK)   = 11
ioctl(11, CDROM_SEND_PACKET, 0xfee47450) = 0
open("/dev/hdd", O_RDONLY|O_NONBLOCK)   = 11
ioctl(11, CDROM_SEND_PACKET, 0xfee474e0) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee474e0) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee474e0) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee45cc0) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee45cc0) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee464c0) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee464c0) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee464c0) = -1 EIO (Input/output error)
ioctl(11, CDROM_SEND_PACKET, 0xfee464c0) = -1 EIO (Input/output error)
ioctl(11, CDROM_SEND_PACKET, 0xfee464c0) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee45e00) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee45e00) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee45a60) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee45b60) = -1 EIO (Input/output error)
ioctl(11, CDROM_SEND_PACKET, 0xfee45b80) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee45b80) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee45b80) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee45b80) = 0

Strace with 2.6.8 kernel:
open("/proc/sys/dev/cdrom/info", O_RDONLY|O_LARGEFILE) = 10
open("/dev/hdd", O_RDONLY|O_NONBLOCK)   = 11
ioctl(11, CDROM_SEND_PACKET, 0xfee1c170) = 0
open("/dev/hdd", O_RDONLY|O_NONBLOCK)   = 11
ioctl(11, CDROM_SEND_PACKET, 0xfee1c200) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee1c200) = -1 EPERM (Operation not
permitted)
ioctl(11, CDROM_SEND_PACKET, 0xfee1a9e0) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee1a9e0) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee1b1e0) = -1 EPERM (Operation not
permitted)
ioctl(11, CDROM_SEND_PACKET, 0xfee1ab20) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee1ab20) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee1a780) = -1 EPERM (Operation not
permitted)
ioctl(11, CDROM_SEND_PACKET, 0xfee1a880) = -1 EIO (Input/output error)
ioctl(11, CDROM_SEND_PACKET, 0xfee1a8a0) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee1a8a0) = 0
ioctl(11, CDROM_SEND_PACKET, 0xfee1a8a0) = -1 EPERM (Operation not
permitted)
Comment 1 František Dvořák 2004-08-26 15:09:14 EDT
Yes, and I forgot info about my HW: DVD writer Toshiba.

[root@finet xine]# hdparm -I /dev/hdd

/dev/hdd:

ATAPI CD-ROM, with removable media
        Model Number:       TOSHIBA ODD-DVD SD-R5272                
        Serial Number:      345C107028          
        Firmware Revision:  1030    
Standards:
        Used: ATAPI for CD-ROMs, SFF-8020i, r2.5
        Supported: CD-ROM ATAPI-2 
Configuration:
        DRQ response: 50us.
        Packet size: 12 bytes
Capabilities:
        LBA, IORDY(can be disabled)
        Buffer size: 2048.0kB
        DMA: sdma0 sdma1 sdma2 mdma0 mdma1 mdma2 udma0 udma1 *udma2 
             Cycle time: min=120ns recommended=120ns
        PIO: pio0 pio1 pio2 pio3 pio4 
             Cycle time: no flow control=120ns  IORDY flow control=120ns
Commands/features:
        Enabled Supported:
           *    NOP cmd
           *    DEVICE RESET cmd
           *    PACKET command feature set
           *    Power Management feature set
           *    Mandatory FLUSH CACHE command 
HW reset results:
        CBLID- below Vih
        Device num = 1
Comment 2 František Dvořák 2004-09-21 14:42:59 EDT
I changed the descrition to be more exact.
Comment 3 Harald Hoyer 2004-10-01 04:11:56 EDT

*** This bug has been marked as a duplicate of 130576 ***
Comment 4 František Dvořák 2004-11-28 08:24:11 EST
It works fine with 2.6.9-1.6_FC2 kernel, cdrecord-2.01.1-0.FC2.1.
Comment 5 Red Hat Bugzilla 2006-02-21 14:05:19 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.