Bug 1310312 - [IMAPx] Cannot mark-all-read in virtual Junk and Trash folders
[IMAPx] Cannot mark-all-read in virtual Junk and Trash folders
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
23
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-20 03:18 EST by htd
Modified: 2016-02-22 08:19 EST (History)
4 users (show)

See Also:
Fixed In Version: evolution-data-server-3.19.91
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 08:19:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description htd 2016-02-20 03:18:11 EST
Description of problem:
"Mark all messages as read" in the junk folder doesn't work.

Version-Release number of selected component (if applicable):
Evolution 3.18.4 (same behaviour with 3.18.5 and 3.18.5.1)

How reproducible:


Steps to Reproduce:
1. Right klick on the "Junk" folder
2. Choose "Mark all messages as read"
3.

Actual results:
Nothing happens.

Expected results:
All messages get marked "read"

Additional info:
Comment 1 Milan Crha 2016-02-22 06:52:51 EST
Thanks for a bug report. I see it works fine with On This Computer/Junk, but not with a virtual Junk folder on an IMAP account. I didn't find anything similar filled upstream, thus let's deal with it here. I also noticed a critical warning on the console before the question dialog had been shown, which is the cause most likely.
Comment 2 Milan Crha 2016-02-22 08:19:34 EST
Created commit f20b3df in eds master (3.19.91+) [1]

[1] https://git.gnome.org/browse/evolution-data-server/commit/?id=f20b3df

Note You need to log in before you can comment on or make changes to this bug.