Bug 1310317 - fdisk -l fdisk double open fd
fdisk -l fdisk double open fd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: util-linux-ng (Show other bugs)
6.8
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Karel Zak
qe-baseos-daemons
:
Depends On:
Blocks: 1356047 1359260
  Show dependency treegraph
 
Reported: 2016-02-20 04:44 EST by Lukas Herbolt
Modified: 2017-03-21 07:27 EDT (History)
2 users (show)

See Also:
Fixed In Version: util-linux-ng-2.17.2-12.26.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 07:27:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (1.29 KB, patch)
2016-02-21 14:33 EST, Lukas Herbolt
no flags Details | Diff

  None (edit)
Description Lukas Herbolt 2016-02-20 04:44:26 EST
Description of problem:
When using fdisk -l, it opens fd to the device (variable fd is global).
This variable is overwritten in function get_boot() and we are losing the previous fd. Once we finish get_boot() the fd is closed in try() (caller of get_boot). But the previous open fd is never closed.

When you have plenty of devices this will could lead to "To many openfiles".


Version-Release number of selected component (if applicable):
noticed it on 5.4 but this bug is in RHEL 6.8 as well 

How reproducible:
strace fdisk -l and check the open files and closed file

Actual results:
The number of opened FD is increasing.

Expected results:
The number of opened FD is constant as we are clearing opened fd.

Additional info:
Provided patch fits to RHEL 6.8, tested.
Comment 2 Lukas Herbolt 2016-02-21 14:33 EST
Created attachment 1129088 [details]
proposed patch
Comment 8 errata-xmlrpc 2017-03-21 07:27:20 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0747.html

Note You need to log in before you can comment on or make changes to this bug.