Bug 1310346 - APR not working with JBoss EAP due to missing 32-bit tc-native and libapr
APR not working with JBoss EAP due to missing 32-bit tc-native and libapr
Status: CLOSED DEFERRED
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Timothy Williams
Wang Haoran
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-20 13:46 EST by leongyihao
Modified: 2016-08-26 16:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-26 16:36:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description leongyihao 2016-02-20 13:46:31 EST
Description of problem:
When trying to enable APR for HTTP connector, JBoss EAP won't start properly. The problem is that OpenShift Online only has 32-bit JVM, while the APR and tc-native in the JBoss EAP module are 64-bit

Version-Release number of selected component (if applicable):
JBoss EAP 6.4.5.GA with 64-bit libapr and tc-native
OpenJDK Runtime Environment (build 1.8.0_71-b15) 32-bit

How reproducible:
Every time

Steps to Reproduce:
1. Create a gear with JBoss EAP
2. Edit standalone.xml. In urn:jboss:domain:web:1.5, set native="true", set connector protocol="org.apache.coyote.http11.Http11AprProtocol"
3. git commit, git push
4. Restart gear
5. rhc tail (check the output)

Actual results:
Exception thrown and app did not deploy

Expected results:
Should works without error

Additional info:
Red Hat need to use 32-bit libapr + tc-native since the JVM is 32-bit. Alternatively, change the JVM to 64-bit
Comment 2 Timothy Williams 2016-08-26 16:36:38 EDT
To resolve this, updates to the java openjdk and apr packages would be necessary. These changes can be intrusive and are not likely to happen unless absolutely necessary. I am setting this bug CLOSED DEFERRED.

I recommend checking out the new OpenShift Online (Next Gen) Dev Preview, where this issue will already be resolved.

Note You need to log in before you can comment on or make changes to this bug.