Bug 1310377 - SELinux is preventing systemd-logind from 'unlink' accesses on the fifo_file 7.ref.
SELinux is preventing systemd-logind from 'unlink' accesses on the fifo_file ...
Status: CLOSED DUPLICATE of bug 1308771
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6387fe815cacdfc89a472126a4a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-20 22:43 EST by Charles R. Anderson
Modified: 2016-02-20 22:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-20 22:58:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2016-02-20 22:43:17 EST
Description of problem:
Boot into Fedora-Live-Workstation-x86_64-rawhide-20160220.iso with enforcing=0.
SELinux is preventing systemd-logind from 'unlink' accesses on the fifo_file 7.ref.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that systemd-logind should be allowed unlink access on the 7.ref fifo_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep systemd-logind /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:systemd_logind_t:s0
Target Context                system_u:object_r:default_t:s0
Target Objects                7.ref [ fifo_file ]
Source                        systemd-logind
Source Path                   systemd-logind
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-171.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.5.0-0.rc4.git3.1.fc24.x86_64 #1
                              SMP Fri Feb 19 19:38:12 UTC 2016 x86_64 x86_64
Alert Count                   2
First Seen                    2016-02-20 22:32:35 EST
Last Seen                     2016-02-20 22:32:44 EST
Local ID                      45f6b704-de7b-48bf-86e1-8a8185c19065

Raw Audit Messages
type=AVC msg=audit(1456025564.577:387): avc:  denied  { unlink } for  pid=1150 comm="systemd-logind" name="7.ref" dev="tmpfs" ino=35491 scontext=system_u:system_r:systemd_logind_t:s0 tcontext=system_u:object_r:default_t:s0 tclass=fifo_file permissive=1


Hash: systemd-logind,systemd_logind_t,default_t,fifo_file,unlink

Version-Release number of selected component:
selinux-policy-3.13.1-171.fc24.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc4.git3.1.fc24.x86_64
type:           libreport
Comment 1 Charles R. Anderson 2016-02-20 22:58:10 EST

*** This bug has been marked as a duplicate of bug 1308771 ***

Note You need to log in before you can comment on or make changes to this bug.